How to know Local App vs. Cloud App in Hub 2.0?


(Chrisb) #1

Forgive me if this topic has already been discussed somewhere. I did a bit of a search and couldn’t turn anything up.

I’m going to be moving to Hub 2.0 sometime next week and would like to try and limit myself to local apps as much as possible in the hopes of improved stability. But, I’m trying to figure out what apps are local apps… stuff that will run off the Hub completely.

It’s easy to exclude a number of them: Anything that requires info from the web (sunrise/set times, info from a outside source like IFTTT, smartapps that interface with things in the cloud). I’ve also heard than any custom app I write will be cloud based, even if it doesn’t need any Internet resources. But, what about an “approved” 3rd party smart app? Can those be local?

So, hoping to clear up my confusion, here’s some questions:

  1. Will an app, if it can be run locally, automatically load and run locally on the hub or do users need to do something to push it to the hub?

  2. Is there an easy way to determine which apps are running locally, and which aren’t?

  3. If a built in SmartThings app doesn’t require outside communication, can we assume it will/can be run locally or are there some even ST created apps that won’t run local?

  4. Can user apps that: a.) Have been submitted and approved by ST and b.) do not require outside communication… can these user apps be run locally?

  5. Can user apps that have NOT been submitted or approved but don’t need outside communication… can these user apps be run locally? (Pretty sure this is no, but thought I’d ask to make sure.)

Anything else I should know re: Locally run Apps that I didn’t ask?

Thanks for any help you can provide… just want to de-mystify the process before I start my migration.


Local v2 Hub Functionality
(Ron S) #2

For the first two questions. May be some v2 owners can answer all of them.

  1. I don’t think you have to push anything on the hub to run locally.
  2. https://graph.api.smartthings.com/localInstalledSmartApp/list

Will motion, multi-purpose sensors and siren work if electricity and/or internet is out?
#3

At the present time there is one and only one smart app that will run locally, and then only if you are using only standard device types. That one is the new “smart lights” lighting wizard.

No other smartapps will run locally. That includes smartthings-created smartapps like the smart home monitor, and the officially published smartapps like everything in the marketplace.

And if you use a custom device type, then that particular instance of smart lights will not run locally either.

But if you have a light switch using a standard device type, smart lights will run locally. And that’s it. Much discussion of this in the forums in the V2 and the local processing topics.

We’ve been told that additional smartapps will be able to run locally eventually, but no particular timeline or process details for when or how things will get approved.

Apparently, the problem is that in order to run locally, at the present time that smartapp must be pushed out in firmware to all SmartThings V2 customers. Since everybody already gets smart lights, including any updates to it, that’s the one they picked for local operation.

I realize this doesn’t fit anyone’s expectations for what “local processing” was going to mean based on previous conversations, including conversations with SmartThings staff, but that’s what we got.

This limitation has been confirmed since the date of the release on September 3 by multiple Smartthings employees, including the CEO and the CTO. So again, check the v2 topics in the forums for additional discussion.


(Chrisb) #4

Thx @JDRoberts,

Good information. Disappointing, but I guess not shocking.


(Bob) #5

I’m no questioning your statement, but I do wonder why this is. A misbehaving smartapp (e.g., one that creates an infinite loop or race condition) running locally only impacts the local user network.But one that runs in the cloud under the same conditions potentially could drag everyone’s response time down. Isn’t the stance on local vs cloud backwards, or is it my thinking that is backwards? I would think that ST would be eager to offload as much as possible from the cloud, thus minimizing collateral damage to users and creating more bandwidth for apps that must be cloud-based.


RELEASE: OSRAM Lightify Smart Dimmer Switch (button controller device handler and smart app)
#6

You have to ask the smartthings folks, I asked the same question. So far the answer appears to be more an issue of the present delivery system, and that updating any local apps requires pushing out firmware to all smartthings v2 customers.

Since a firmware update takes the hub off-line temporarily, this could be a real disruption in service for the entire customerbase


(Bob) #7

Thanks JD!

@Tyler (or whoever), any input on this?


(Robert Robinson) #8

I just got my V2 hub up and going, installed and setup the Smart Lighting App, which I thought ran Locally. When I go to https://graph.api.smartthings.com/localInstalledSmartApp/list it says there is nothing running locally.


#9

It also depends on the device types that you are using for the devices which are included in each individual smart light rule.

For example, Philip hues do not run locally. And no custom device type runs locally.


(Robert Robinson) #10

I have nothing but z-wave switches and zigbee plugs for all the lights. No customs or Hues.


(Chrisb) #11

Try pulling the ethernet cord from the hub and testing some of the rules. See if they work.

My guess is that “show local running apps” thing isn’t fully operational right now. Seeing as only the one app runs locally, there isn’t much of a need for it to be ready.


(Larry) #12

seems to be working for me…i have the following rules

Installed Smart App

Installed Smart App ID

Family Room Lamp Fim at 10:00 PM and off at 12:00 AM (Nh)

Family Room Lamp On At sunset (Nh) 0b3f9e8c-4e5e-4690-bca3-a2f70260
Turn on Deck Floods when Slider Deck Door opens (Nh) 0f581c8f-d95af-b349-85aab601db55
Turn on Deck Floods when Deck Door opens (Nh) 1cf5d764-1fdc-4224–8976070782cc
Motion Turn On Family Room Lamp (Nh) b5cdbf7b-82a5-44fd-b725-98ce553db
Front Door Lights On Front Door opens (Nh) d35d78fb-eb9f-4cf7-b3ec-249167bb3
Cindy Garage Door Opener Toggle (Nh) f6aa8d78-29ac-4712-b7cf-ddc76baa205

Copyright © 2015 Physical Graph Corporation


#13

Is the minimote working as Local?, I’m trying to use the minimote to control zwave switch (Aeon Labs DSC06106-ZWUS) and a GE Link Wireless BR30 but is not working in any case, Am I missing something? ( I am using the Smart Lighting app wizard for this)


#14

Since the GE link is not in the official " works with SmartThings" list, that may be what’s making it ineligible for local processing. What device types are you using?

When you go to this link, what do you see in the table?

https://graph.api.smartthings.com/localInstalledSmartApp/list


#15

Thank you for your awnser JD. Well, I’m also testing using an aeon lab switch Aeon Labs DSC06106-ZWUS (according to the compatible products you linked, it’s supported: Aeon Labs Smart Energy Switch Energy Switch Z-Wave).

The weird thing is that if I go to the link for the local apps you mentioned, it appears one for the GE Link (turning on and off at a specific time…which I haven’t test it without internet yet)


#16

Each instance of smart lights which is eligible for local processing should show in that table. So there should be one for each rule.

It sounds like the GE light is probably using the generic bulb, so that’s good.

What device type are you using for the Minimote?


#17

mmm, checking the GE Bulb, the Type says GE Link Bulb. For the minimote the type says Aeon Minimote


#18

Try using smart lights to set up a rule that does nothing except turn on the GE bulb with one button on the minimote, and then see if that shows up in the local table.


#19

After upgrading the minimote to version 1.19 I deleted the minimote from the hub and the repaired it. After doing that, I tried creating a new rule for the switch, and this time it appeared in the local table. For another GE Bulb rule that also was not appearing in the local table, I did the same (delete and repair), and now it appears the new rule. I tested disconnecting the hub from internet and the minimote worked without issue!


#20

Awesome, thanks for letting us know. :sunglasses: