Lousy experience with Homeseer HS-WD100+ and HS-WS100+


(Aud) #1

I finally got my hands on the new Homeseer dimmers (HS-WD100+) and switches (HS-WS100+). With very little effort I was able to set up the configuration according to my plan: double-tap on any dimmer/switch turns on/off all lights everywhere (thanks to Darwin for the device handler). However, the accomplishment is bitter-sweet. Overall experience is quite lousy.

First, Homeseer dimmers, like GEs, don’t have configurable minimal brightness level or the short boost at start. I tried variety of bulbs, and all off them - including Costco’s FEITs which have really broad dimming range - have the same issue: if the dimmer is turned off while at the lowest level, turning it back on brings up the zombie-apocalypse style random strobing. You have to go up and then back down to fix that, every time. Even the cheapest dumb LED-compatible dimmer is able to deal with that by having a very brief brightness boost at start.

I tried to workaround this via automation - turn brightness to the higher level automatically when lights are switched on. But that takes 2-3 seconds, during which my family members begin manually adjusting the brightness. Automation suddenly overrides it makes them feel as if dimmer is acting randomly.

Second, the double-tap action takes 2-5 seconds. It’s enough time to start wondering if it will work at all (although it does work 100%). This is absurdly long time considering the tiny amount of data transferred and trivial logic required for this action. Smart Lighting app runs on the hub, there is no referring to external resources - how can it take more than 10 milliseconds?

Third, simply turning the lights on isn’t instant. It takes 1/2-1 seconds between tapping the switch and hearing the click. That is enough time for my kids to come to conclusion that the tap didn’t work, so they tap again, which registers as double-tap and 5 seconds later all lights are on.

Fourth, there is no option to either turn lights to the pre-set brightness (instead of last brightness), nor there is a shortcut to the full brightness. I tried achieving both via use of triple-tap/Smart Lighting app, but that takes same 2-5 seconds during which people start adjusting brightness manually just to get it overridden later.

I suppose none of these is a disaster and one can get used to these quirks, but how much of expierence and convenience is it worth sacrifying for the sake of Smart Home?

All the issues above seem fixable programmatically, if only the code worked faster. Maybe the solution is to implement things in the device handler itself? I have some programming experience and could take that challenge, but before I start - may I ask for some expert advise.

Is the following doable in the device handler, and would it work in milliseconds instead of seconds:

  1. If dim level is below 20% when turned on, increase brightness to 50% for 0.1 second and go back to where it was
  2. When turned on, set dimmer brightness to configurable level (in 0.1 second or less)
  3. Refer to other lights directly from the device handler, not going via Smartlights app, for fast double-tap response

Or any other advice how to deal with the issues above would be greatly appreciated.

And yes, the “new” Homeseer switches/dimmers really are just old DragonTechs with a Homeseer sticker covering DragonTech logo in a home-made packaging.

Thanks!


New Leviton In-Wall Dimmers
[RELEASE] Button Controller Plus, HS-WD100+ HS-WS100+
Decided on SmartThings...help with devices!
#2

Sorry to hear about all the problems, hopefully others who have the devices will be able to comment.

Meanwhile, regarding the Dragontech issue…The case and the antenna are the same, but the firmware is very different. The Homeseer switches are certified for the Z wave “central scene” command set. The DragonTech are not and do not support those commands. The DragonTech also do not support instant status update. You can see the difference in the conformance statements on the official Z wave alliance website. So not the same device even though they use some of the same components.


(Aud) #3

Thanks JDRoberts.

DragonTech is bragging about the over-the-air firmware update feature. I wonder if Homeseer has that ability as well and if there is a hope that the issues I mentioned would be eventually fixed in the new firmware.


#4

OTA firmware updates are supported by the zwave plus protocol, but I don’t know if SmartThings allows it.

@duncan ?


(Dale C) #5

It would be nice to see it react faster but like you say, I just learn to live with the short delays


#6

With reference to the noted time it takes before something happens, and the comment that was made re “Smart Lighting app runs on the hub”, my 2c worth…

Subject to correction I think you are wrong. This is a CUSTOM DEVICE handler I believe, which means the Smart Lighting is NOT local on the hub, and everything is done via the cloud. Assuming I am correct, this will explain / account for the very long seconds you have mentioned before actions occur. Similar observations abound re other custom switches, motion detectors etc.

Check the following 2 links to see what is running locally:
https://graph.api.smartthings.com/localInstalledSmartApp/list
https://graph.api.smartthings.com/localDevice/list

J


#7

@GatVlieg makes a very good point: the official smart lighting automations are eligible to run locally, but only can run locally if all of the device handlers being used in the automation are also eligible to run locally. And at the present time that is limited only to the officially published device handlers, and not all of those.

For example, Phillips hue bulbs are not currently eligible to run locally, so if you include even one of those bulbs in your smart lighting automation, that particular automation will not run locally. :disappointed_relieved:

Depending on which server your account runs on, the links to check what is eligible to run locally on your own account are different. The community-created wiki has all six of the links:

http://thingsthataresmart.wiki/index.php?title=FAQ


(Aud) #8

Thanks for the hint. Turns out I have one scheduled bulb running locally. Everything else I built out runs in the cloud… Which is mind boggling - why?? I’m new to home automation, and every day brings a new discovery. It takes forever for Samsung/Smartthings to implement official device handler, and community gets it done very rapidly. Why would they not permit us take full advantage of custom device handlers?

At this point I gave up on faster response times for double-tap. But I really need to figure out workaround for the zombie-apocalypse flickering when dimmer is turned off/on while at lowest level.

I inserted “zwave.basicV1.basicSet(value: 50).format()” to on() method in Darwin’s device handler and it did the trick for remote on. Now whenever I turn the dimmer via double-tap of another dimmer, or via the app, it instantly gets to my preferred default 50%. However I wasn’t able to find a way to quickly get to default level when dimmer is turned via physical tap. zwave.basicV1.basicSet seems to do absolutely nothing in that scenario, no matter where I put it.

Any help would be greatly appreciated.


(DavidK) #9

@Aud
I was waiting for some others in the community to comment on this. Do you have experience with any other zwave dimmer other than homeseer?

As a way to compare the deficiencies of homeseer to the limitations that all zwave switches might have?

I think that most zwave switches on single tab go to last dim level and do not have a settable default value.

Also for example, some LED bulbs will flicker at low dim values. So your flicker issues may be related to LED brand and not the homeseer switch.

Also, can you run zwave repair without any “failure” events in the log?

On this page click on zwave repair:
https://graph.api.smartthings.com/hub/utilities/6fa85269-a9cf-4640-b7a8-f1000f68f9c9

On this page wait until you see the line that says see wave repair finished and then make sure there are no lines that state “failure” if their are, run zwave repair again:

https://graph.api.smartthings.com/hub/6fa85269-a9cf-4640-b7a8-f1000f68f9c9/events?source=true

This page must be manually refreshed, but it is the easiest to read for zwave repair, none of these log screens are easy to read, but I find this is the easiest.

If the zwave mesh is not “fully” mapped you can still have communications, but will have delays.


(Aud) #10

Professordave,

I got access denied on both of your links, but I ran zwave repair from the iphone app and there were no errors.

I only had GEs, which I returned to Lowes. They didn’t have true double-tap support, which was the main reason I wanted smart dimmers/switches in the first place. The “Double tap” app and the “Better double tap” app didn’t work either.

GEs had exactly the same issue with LEDs.

And let me clarify the issue. It’s not about low dimming range, like some cheaper LED bulbs have. I can dim these bulbs to the lowest setting without any issue and they work great. The problem is that they can’t START at lowest level.

I have some very basic dumb LED dimmers. If you set them to the lowest level and turn light off, next time you turn them on they’d go to ~50% for like 0.1 second and then back to the lowest setting and all bulbs work just fine.

There are two solutions for the flickering. Either one is sufficient:

  1. Configurable lowest level
  2. Brief boost at start

Neither GE nor Homeseer does either of the above.

It’s not a deficiency of the circuitry. I suppose either of the solutions could be implemented in the firmware. Or even in the device handler, if only it could run locally.


(DavidK) #11

@Aud
You are correct, so I have no advice.

I had forgotten that when I first started installing things that I noticed that there is a different “curve” or whatever you call it if you dim UP versus dim DOWN. The behavior on the lights is different dimming up versus dimming down.

Also, I had tried a long time ago to use the double tap apps, and even when it worked it did not work that well and just abandoned trying to get that to work.

As far as the zwave repair, I would recommend checking the logs as I never get any feedback on my iphone.

Go to here:

Then here to see events

Between the “Z-Wave network repair started” and Z-Wave network repair finished" where there any failures for any devices?


(Justin Tan) #12

Also just installed a few homeseer switches, mainly so I could have the double tap functionality.

I also am disappointed with the on/off speed. Mainly the “on” speed. When I tap once to turn on my lights, I’d like them to just turn on to the last brightness instantly (usually max). Instead, it takes about a second to register… then it fades up over 1-2 seconds. I can live with the 1 second initial delay as I image it’s going to the ST hub and into the cloud and back, but is there a way to just tell it to flip on to the final target brightness setting rather than fading up?


(Roger G) #13

@JDRoberts @erocm1231 @duncan @Darwin

I am trying to get the Homeseer WD100+ dimmer to turn on based on motion activation from Homeseer HSM 200. The best I can get is about 1.5 secs, which is noticeably delayed. ( In the same setup, using HSM 200 with Leviton DZMX1-1BZ , I was able to get 0.5sec response. )

Any tips on how to get the WD100+ to respond faster to motion detected by the HSM 200?


(Eric M) #14

The added delay may be because the Homeseer has a handler that doesn’t support local communication and the Leviton does? Also, from some of these posts it seems the Homeseer switch just by default has some delay.


#15

That’s my guess as well. I’ve seen reports on other Z wave forums that most devices using central scene commands are a little slow.

It would probably be a good idea to do a Z wave repair anyway, just to tuneup the network, but I don’t know if you’ll ever get the same speed as the Leviton.


(Alfred Dixon) #16

Leviton has instant notification covered with a patent and hence generally higher cost. The good news is that the patent expires this year, the other switch people (e.g. Homeseer & Dragon) will be issuing new firmware very soon and 'hypothetically" provide the same response.


#17

That’s not quite what’s going on.

The patent is actually held by Lutron. And they have two patents which may cover this kind of notification. Only one of which expired this year.

Leviton and Cooper both license both of the Lutron patents, so they’re covered.

The Z wave alliance gave them a method to implement this through the “hail” command set.

If you check the official conformance statements filed on the Z wave alliance website, you can see which devices support “hail” and which don’t.

http://products.z-wavealliance.org

what’s in a name? “Instant status” using three different Z wave methods

All of that said, there are two other methods by which zwave devices which do not license the Lutron patent can achieve a similar end result. The term “instant status” itself was not trademarked. So other companies can say that they offer “instant status” even if they didn’t license the Lutron patent

The first is to use “association,” including the hub itself in the Association group. The hub then ignores the command to turn on or off, but takes note of the fact that the command was sent.

The second is to use a new command set, “central scene.” With this, the device sends a scene number to the central hub which then turns around and issues the command to the light. For technical reasons, this is not a violation of the patent.

Homeseer: “instant status,” but not “hail”

The homeseer switches introduced in 2016 say they offer “instant status” and because of the timing many people, including myself and @duncan , assumed that meant that they were going to use “hail” even though they hadn’t paid Lutron for a license. But it turns out that they didn’t – – they implemented their version of instant status by using the central scene command. Their devices do not support hail.

So far, no one who hasn’t licensed the patents has announced a new device using hail. It looks like everyone is waiting for someone else to test the waters on that second patent. Lutron protects its patents very aggressively, so we will know quickly if the second patent is still applicable or not.

I know there’s a lot of discussion on Home automation forums with people who only considered the application of the first patent. But if you look at the licenses you’ll see that everybody from control 4 to Leviton who licensed the first patent also licensed the second.

So… The Homeseer version of “instant status” doesn’t have anything to do with the Lutron patent one way or the other. It’s using a different methodology, central scenes. :sunglasses:


(Alfred Dixon) #18

Thank you for such a comprehensive reply.


(Fernando) #20

I was about to buy 30 of this homeseer dimmers :s dont know anymore… WHat do you guys recomend then? I found leviton very confusing, there are many model numbers, not always available to buy etc etc…


(Jg506) #21

I recommend that you buy most of your switches GE and buy Homeseer only for locations where you actually plan on using the double/triple-tap/hold feature. I have about 50 switches only 6 of them are homeseer. The lack of local hubv2 support with these switches has few practical drawbacks. For me the most annoying drawback is the inability to get correct state with homebridge for iOS. Other issues might be delayed response time (cloud roundtrip) in all cases except single tap on the switch itself. For me the cloud round-trip delay is unnoticeable but ymmv (as others noted here). Also these switches will not participate in any automations that can run locally on the hub (an issue only when your internet connection is down, at which point also only single tap will work).