Lost developer access

I’m just starting with this but every time I login to the IDE I have to request for developer access in order to setup new device types. And any new device I make end up disappearing every hour or so. I assume I’m doing something dumb? I’ve tried deleting devices and then device types to start over but the device types won’t delete because they say a device is using them, even though I can’t see them in my devices. Any help is much appreciated.

Are you in the UK - if so there is an issue where the system can swap between https://graph-eu01-euwest1.api.smartthings.com/ and https://graph.api.smartthings.com/. Just bookmark the former for the moment and go via that one.

Thanks, timepilot. Unfortunately that’s not the case. This morning I checked again and I lost developer access and had to request it again.

It’s strange though. Yesterday I setup a Nest device type and then a Nest device. It was working well for a couple of hours and then the device just disappeared from my devices. If I try to delete the device type to start over it says that it’s still in use by a device. The Nest also still shows up on my Smarttiles and changes made on the Nest at my home show up in my Activity feed. It’s like it’s still there but hidden.

I’m not having any issues with the MyQ Devices/Device Types/Smart apps.


So I figured out how to delete my hidden Nest device. I had to go to My Locations and delete it from the ‘List Devices’ page. I was able to delete and then recreate and now it works again. We’ll see if it stays working.

But I still lose developer access and have to rerequest it every time I go to the website. Is that normal?