SmartThings Community

Logitech Harmony (Connect) Updated?

I am having this same issue… is this a ST issue?

Yes…same here…20 char…

Update: obviously the new app is “experimental”. What I found, is that IF you don’t select any of your Harmony activities, the connect works just like before. If you need to set triggers, using the trigger app from Marketplace works too (or at least it works for me)

1 Like

It’s broken. I think a new version was pushed out with the recent firmware update, but that’s the one that crashes. :scream:

Report it to support so they can let you know when it’s fixed.

What?! SmartThings released broken code? Noooo… That never happened before.

These types of comments are getting old and are not helpful.

They put back the harmony trigger App in the marketplace, probably as a workaround.

So if the harmony connect section about activities/triggers crashes for you, then only use the connect smart app to connect the hub. Don’t touch the fields that list activities or triggers. Then after you’re done, go to the marketplace and get the triggers app to set up the triggers.

You can follow the steps in the old FAQ:

Seems like everything is working now. The harmony (connect) smartapp can now create it’s own virtual switches. Works much better than using the Logitech trigger app.

1 Like

Should delete the virtual switches I made the old way using the triggers app and just go thru harmony connect? Does it clean it up a bit?

Yeah, that is what I did. It’s a much simpler and cleaner approach.

Do you know if Alexa can still
Find these new virtual devices?

I haven’t tried it yet, as I have been using IFTTT’s new phrase trigger. However, the new virtual switches were discovered by the alexa app. So, I imagine they would work fine. In fact, they would work better as toggle the switch toggles the activity off. You don’t need to create a separate virtual switch for the power off activity.

1 Like

Perfect thank you forgot to ask you that, thanks gonna give it a try when I get home too.

Okay, so just tried it with Echo and this is odd…

I created a new group called Living Room TV, added my Watch TV virtual switch from smartthings. Similar to how I had everything prior to the updated logitech app. I asked Alexa to “turn on the living room TV” It turned on fine, but alexa’s lights kept spinning and she eventually said “that command does not work on that device”. I asked alexa to “turn the living room TV off” and she said okay.

I checked the device type of the switch in smartthings and it is in fact a switch. Not sure why Echo is having a problem with it. Maybe someone who knows more can chime in here…

I think someone said it seemed like “TV” has now been added to the list of reserved words that echo keeps it self, and can no longer be used as a switch name.

I’m having the same weird issue, named device tv, and it will turn on just fine with echo, turn off not a chance. What’s the solution? Rename? T.v? Television?

Yeah, I think you have to rename “TV” now. I wish Amazon would publish a list of these. This happened to me with the switch I called “power.” Great for about 6 weeks, after that it would turn off the echo itself.

BTW, you can easily test this by just creating a group in Echo with your new name and putting your “TV” switch into that. If it’s the name being a reserved word that’s the problem, saying the group name will fix it. :sunglasses:

I don’t think it has anything to do with the name. I have several other devices, Roku, Xbox, PS4 and Alexa gives the same error message when asking to turn them on. It’s odd that they still work though. Meanwhile Alexa’s blue light spins for an abnormally long time before saying that command does not work. Asking Alexa to turn off a device produces a similar result, but she actually says “OK” more often than not.

If Alexa gives you the message that the command does not work with that device, then there is a problem with the integration with SmartThings, and you probably have to unlink your SmartThings accountand relink it again. This happened to a lot of people this week.

If Alexa gives you the message that she cannot find the device, or doesn’t respond at all but just comes on and then turns off, then that is often associated with the device’s specific name.

Just tried forgetting all the devices, unlinking Echo from smarttthings and relinking. I then had Echo rediscover all devices. She found all the virtual harmony switches without any problems. However, I did notice they were listed as devices and not switches. I wonder if the “turn on” command does not work with that category. I tried other commands, but nothing seemed to work.

Oh, I also put each switch into its own group so I could change its name to something more friendly. Again I do not get a message saying Alexa can’t find the device, only an error saying that the turn on command does not work with that device. The TV still turns on fine though.

Yes, “devices” has been a problem before. It’s SmartThings that tells echo what kind of device it is, so that would have to do with the SmartThings device type.