Why is Logitech Not An Option When Adding Device Using SmartThings (Samsung Connect) app

I’m just trying to add my Logitech Harmony Hub to SmartThings using the new SmartThings app, but Logitech is not an option. I feel like I’m missing something so obvious here. I’m following the instructions found here for the new app:

I can add Harmony Connect using the SmartThings Classic app, but my Harmony activities do not work right. For example, when I turn an activity on, the virtual switch for the currently running activity doesn’t turn off.

Many Thanks

I noticed they removed the integration in the new app 5 days ago. Don’t have an answer as to why it was removed.

Only advice I can offer is to install the Classic app and set up the integration there. It is still available in the Classic app.

1 Like

Thanks, but when I turn an activity on, the virtual switch for the currently running activity doesn’t turn off. Is there any way to get my virtual harmony activity switches to work like my Harmony remote?

I’ve just had to redo my Harmony Hub activities because I got a new TV. I noticed it took several seconds for the Activity switch to turn on, and didn’t see it turn off when I selected a new activity. This is all on the Classic App.

That said, my hub’s been acting a little strange lately…not sure if the issue is at my end or Logitech’s.

Although Harmony is still not showing up in the new SmartThings app. I used the Classic app and followed the advise here to get the virtual activity switches to sync:

1 Like

Are you aware if Logitech will be added back to the available brands in the future?

where can I get the classic app?

You can install Harmony in the new app, by doing the following:

In the IDE, Create a New Smartapp, From Template. In the list is Logitech Harmony (Connect). I believe you just need to save and Publish it and then it will be on the list of Smartapps in the ST apps.

Once the SmartApp is installed, open the ST app and go to the SmartApps section. Click on the app and it should launch into the setup app.

Why this is not included in the new app, I do not understand , but it is a valid workaround.

So, I followed your instructions. When I launch the setup for the Smart App on my IOS device, I get a “Something went wrong. Please try to install the SmartApp again.”. To fix it, I needed to go into the Smart App in the IDE and enable OAUTH.

When attempting to setup the SmartApp in IOS, I get a ‘Missing or invalid argument’ when I click on the ‘Click to enter Harmony Credentials’ link.

I am getting this message as well. I even Uninstalled and reinstalled the smartapp.

Same issue… had to enable OAUTH but now getting invalid_argument…

use the logitech harmony app to set up the integration to ST

if i do that, from the Harmony App it will allow controlling smartthings devices. i want to add my harmony activities into smartthings…

Tagging @nathancu

It should, you have to do all of these steps

  1. Setup the integration from the harmony side using thier instructions. https://support.myharmony.com/en-us/harmony-experience-with-smartthings
    It Should add the Harmony Connect smartapp to your IDE.
  2. Open the newly added harmony Connect SmartApp on your phone inside SmartThings and configure it.

FYI on Step 2 - people have reported having to wait for a ‘few minutes’ when searching for your hubs and activities.

If that doesnt work you’ll probably need to contact Harmony for help

1 Like

Thank you.
i went ahead and deleted eveything (removed smartapp from IDE, removed ST from Harmony) killed all apps and tried everything again from scratch and that resolved the issue.

for others:

  1. Go to IDE and remove any lingering devices / smartapps with the name (logitech harmony).
  2. Go to Harmony App and follow https://support.myharmony.com/en-us/harmony-experience-with-smartthings . if ST was already connected, relogin and re-approve the ST devices you had.
  3. Wait a minute and go back to ST --> smartapps --> add smartapp --> harmony connect.
  4. Login using your Harmony credentials.
  5. Reconfigure everything.

Thank you guys !!!