Linear WO15Z-1 Nuisance with LED light


#1

I have a question about the SmartThings integration with my Linear WO15Z-1 wall outlet. The wall outlet includes a status LED (on/off). Since I paired it with SmartThings, the LED functionality seems reversed. The LED lights up when it is not powered and turns off when it is powered.

Per the manual for the Linear WO15Z-1, the LED can be configured for default operation (LED on = powered on, LED off = powered off) or “night light” operation (LED off = powered on, LED on = powered off). The manual identifies configuration commands to control this functionality. Does the SmartThings support these configuration commands? Is there a way to get the switch back to the “default” configuration that I desire?

I have removed and repaired the device several times, with the same result each time. Help!


#2

I’m tired tonight, but hopefully someone else can explain the Z wave tweaker, which is a custom device type handler. By temporarily assigning the device to the tweaker, you’ll be able to reconfigure any of the parameters. Then once you have reconfigured them, you will reassign it to its original device type handler and The parameters will remain the way you set them with the Tweaker. :sunglasses:


.


#3

Thanks for the advice - I’ll give the “tweaker” a try!


#4

In case this helps anyone else - the Z-Wave Tweaker worked wonderfully and solved the problem. After using that solution however, I came across a more simple answer. My original device type for the WO15Z-1 was a Z-Wave relay. If you simply use the device type of Z-Wave switch, the settings in that device type allow you to control the LED properties.

Hope this saved other folks some time!


(Alex C.) #5

Something’s not working right for me and maybe someone can help. I’ve set my device to a Z-Wave switch and the LED properties help, but they’re reversed. I’ve plugged a light into the switch and when I set the properties to “When Off”, the LED is on when the load is On. When I set it to “When On” the LED is on when the load is off, and setting it to “Never” leaves it always on. I tried using Z-Wave Tweaker and set ParamID to 3 and ParamValue to 0, but things still seem reversed. Any thoughts?

-Thanks.