Linear Door-Windows Sensor WADWAZ-1 (GoControl Home Security Suite)

sensor

(Ruben Garcia) #1

Hi
I recently bough GoControl Home Security Suite (Essential) wich includes two Door-Window Sensors (Linear WADWAZ-1) and one Motion Sensor.
I have SmartThigs v2 hub and I paired the motion sensor without any issue, bit I can’t pair the open/close sensor with the hub. I can’t access the inclusion mode in the sensor. I followed the instructions provided in the box, but nothing. The sensor displays a fixed red light, with no blinking when I insert the battery.
Please, help!!


#2

@rubengarcia, try excluding the device (General Exclude in the app) and try again. On the device make sure to hold down the tamper/program switch for a second and then you’ll see the app return the message about successfully removing a device.

Make sure that no other zwave device is being used when you run a general exclude.

You could potentially have a crappy battery, or even the device itself could be bad (worse case).


(Ruben Garcia) #3

Thanks for the help!!
Question: what do you mean with “Make sure that no other zwave device is being used when you run a general exclude”??
I have to remove batteries from the other devices? Or Just need to not trigger the devices??


#4

Correct, but usually just things like switches. Those usually just need a press of a button to be excluded, so a general exclude can easily catch those by accident.


(Ruben Garcia) #5

Thanks a lot!
It worked!!


(Heber) #6

apologies to cut inhere, now that you guys are on this subject, I order several of these sensors, my question for you expert is can you program in the inclusion process the "standard’ built in side sensor and the two-screw “auxiliary” one as TWO separate windows-doors?
Just wondering because on a standard Honeywell Alarm System wireless sensor you can use a single sensor as two separate windows or doors utilizing the two screw auxiliary connection.
Thanks.


#7

No, it’s seen as a single device and it will report it’s state whether the magnet trips the side reed switch, or if the internal screw terminals are used.

EDIT. Please see the posts below, especially the one from @krlaframboise. No matter how Iong I’ve been using this stuff, I learn something new every day!


(Heber) #8

Thanks for the swift response.

Very appreciated.

Heber


(George) #9

The instructions for the Linear version of the sensor do specify that you can distinguish between the reed switch and dry contacts. (Alarm event 0x02 vs 0xfe)

The firmware might be different in the GoControl version though (for example, the Linear motion sensor and the GoControl version of same sensor have different firmware)

If it’s same firmware, and you can distinguish between the internal/external sensors, you could use it as proposed. Would need to modify the DTH to send different events depending on the the alarm event, and would need a helper app to subscribe to the DTH event and send it to a virtual contact sensor. Would end up with two devices, one being the physical contact sensor and the other a virtual one.


(Kevin) #10

No, but my DTH for the GoControl Contact Sensor changes the contact attribute based on which ever one changed last and it also has the attributes “internalContact” and “externalContact”. That allows you to use a SmartApp like CoRE to perform different actions based on if the internal or external contact changed.

These devices go by several names and some have different firmware, but the Linear and GoControl versions use the same manual and product number so I’m pretty sure they also have the same firmware.


(Heber) #11

Nice!
Tnx.


(Liren Sun) #12

I have problem with the windows sensor with v2 hub too. I do know how to set sensor to inclusion mode, and I am seeing the light blinking. I have no problem connect and remove this sensor with my v1 hub. It seems to be a hub issue. Here are some of my hub info. I have zwaveControllerStatus: 01 in my v1 working hub, but 09 in this v2hub. Does it matter?

presenceTimeout: 2
updaterVersion: 75
uptime: 40276
videocoreVersion: 0.8.16
zigbeeChannel: 15
zigbeeEui: D052A8A662420001
zigbeeFirmware: 2.1.10
zigbeeNodeID: 0000
zigbeePanID: 3298
zigbeePowerLevel: -6
zigbeeRadioDetected: true
zigbeeRadioEnabled: true
zigbeeRadioFunctional: true
zigbeeUnsecureRejoin: false
zwaveControllerStatus: 09
zwaveHomeID: C436603B
zwaveNodeID: 01
zwavePowerLevel: full
zwaveRadioDetected: true
zwaveRadioEnabled: true
zwaveRadioFunctional: true
zwaveRegion: US
zwaveSerialVersion: 4
zwaveSucID: 01
zwaveVersion: 3.83


(Damon Blumenstein) #13

Kevin, If I use your DTH, is there a way to detect if EITHER contact is open and just call it an open sensor rather than whichever happened last? I have a dual window, and if I have them both open and then only close 1, there is no security in place anymore since the sensor now reports all closed since that was the last signal. Does one of the stock DTH handle the inputs like this?


(Kevin) #14

I don’t believe the stock device handlers work with the external sensor, but I could be wrong.

I need to make some changes to that DTH soon so when I do, I’ll add a setting that allows you to change that behavior. I’ll try to make this change some time this week.

The Monoprice Door/Window Sensors look the same as these, but when the external contact is enabled, the device won’t report closed unless both are closed.


(Damon Blumenstein) #15

ok great, thanks for working on that for me. The ones I have are the Go-Control (from the security suite) so I presume just changing to the monoprice DTH won’t help is what you are saying?


(Kevin) #16

Correct, the Monoprice devices physically work like that so it has nothing to do with the DTH.

Another option is to create 2 virtual contact sensors and use CoRE to change their closed state based on this device’s “internalContact” and “externalContact” attributes.

It would be a pain to setup and you’d probably have to search the forum to find a virtual/simulated contact sensor DTH that allows you to manually change their state, but it would solve your problem.


(Damon Blumenstein) #17

I actually know how to setup the virtual switch, but I can’t figure out how to detect which of the 2 contact types to read off of, do you have a screen shot or can you explain that one? This is what I was trying originally but couldn’t figure out how to tell which contact I was reading and how to do both.


(Kevin) #18

The internalContact attribute is the physical device and its magnet, the externContact is the one attached to the terminals.

It’s a little more complicated than I originally thought because CoRE doesn’t allow you to enter a value when using a custom attribute so you have to create a variable with the value “closed” in order for this to work.

To create the custom variables:

  1. Open or Create a New Piston
  2. Scroll down near the bottom and tap “Local Variables”.
  3. Tap “Initialize a variable”.
  4. Type closed into the first field and closed into the second field.
  5. then tap “Initialize”
  6. Tap Done three times to get back to the main screen of the piston.

Setting up the Trigger/Condition

  1. When setting up the trigger/condition Select the actual device and choose “internalContact” for the attribute field instead of using “contact”.
  2. Use whatever you want for the “Comparison” field.
  3. Use the “or choose a variable to compare” option to select the closed variable you set up earlier.
  4. Use the “when true, do…” and “when false, do…” fields to set the open/closed state of the virtual device you created for the internal sensor.
  5. Repeat steps above using the externalContact attribute and the virtual device being used for the external contact.


(Damon Blumenstein) #19

Kevin, I am not getting the option to select internal contact, what I am doing is selecting piston mode “Basic” --> “IF…” --> “Add condition”–> Capability “Contact Sensor” --> “Dining Room Window” -->

Now the only option I get is Comparison where you show Attribute

Was I supposed to do something different than the basic piston and an IF statement?


(Kevin) #20

I didn’t realize that was only visible when you have “Expert Mode” enabled.

If you want to enable it, go to the bottom of the page that lists all your pistols, tap settings, and enable it.