Light wave L82 relay integration

Hi everyone, great community you have here.

I’m U.K. based and I’m heavily into the SmartThings and lightwave tech.

I’ve got all of my lightwave devices within SmartThings except the single L82 relay I own. Obviously that appears within the lightwave app and is controllable.

Is there something I’m missing? Is this device not supported yet?

A google and a search of this forum hasn’t shown anything obvious up.



So I actually solved this. If there’s any interest I’ll post the work around.

If not i won’t waste my typing XD

I have the same issue, and would like to understand how you solved this.
Many thanks

Hi @andysmith13. Sorry it’s taken me a while to reply.

The fix was the following. Within the lightwave app, create a “dummy” gen1 socket. Which you do by going to “add”, then “link connect series”, “power” and “socket”.

Once that’s made you use a lightwave automation to mirror that dummy socket to the relay.

The dummy socket shows up in smartthings and will therefore control the relay from there.


1 Like

Hi Dave
I’m also a big lightwave user, I even modify the door contacts to work on my PIRs so I have garden detection, this can then switch different lights on and off in the house as well as the floodlights, then along comes ST , now I have lightwaverf and ST linked, but I would like to know if I can use the temperature sensor built into most ST units to turn on my heating, I can not see lightwave thermostat in the ST app , is this possible? Many thanks Darren

Thinking on what you put, I created a socket (fake one) and made an routine in lightwaverf, then used that socket in ST , which likes like it may work, open my eyes up, so thanks for the post

I have no Idea in regard to heating. Just this problem that I found a fix for.

I’m with Hive for my thermostat and TRV’s. I’ve got that working in smartthings too

1 Like

Hi Dave
No that info you give above is just what I needed, I made a socket on lightwave called “not real” and set an automation to set “when on” to turn the thermostat to 22 degs and then the TRV to 22 degs , then the “not real” appears in the ST app, I then set a rule when motion is sense/temp/time is meet it turns on the “not real” socket, bingo , if no motion heating off all thanks to you :+1: