LIFX smartapp is missing from classic app marketplace

Hi all,
I wonder if any one else has this issue?
A few weeks ago my LIFX lights stopped working.
Probably due to the auth token had expired.
I could not cause the app to generate this again, so I asked smart things support for help.
They told me to remove the app and reinstall it, and so lossing all the lights configuration I had.
I did this, only to find out the classic app marketplace no longer has the lifx smart app.
Oh my god! how can I get control over my lights back?
I was asked to use the new app, but there I find a lot my my setup is missing, so I will have to redefine my whole house again.
What to do?
Niv

1 Like

You should use the new app to add your LIFX devices back. A new C2C integration is ready through the new app. It will add the devices back. The only difference what you will see in the classic app, that the DH tiles looks different and you cannot change the icon.

The basic control will be available in the classic app, but you should be able to fully control it through new app really.

You don’t have to go all in on the new app yet. I’m running both.
I got the new app up, got the lifx configured and my lights work, I didn’t have to rebuild anything that used the lights.

I did have a weird occurrence where I had 2 of every lifx light in my new app. The ones I’d sorted into rooms, and new ones I hadn’t sorted. I deleted the old ones and sorted the new ones and everything continued to work. Not sure if this has happened to anyone else or if what I did was right.

@GSzabados initial state in the new app was that in the gears, lifx was defined.
Yet the new app did not show all the lights.
So I removed it and redefined it.
Now I see all the lights in the new app. but they are not fixed in the classic app.

@RVoodoo Thanks for your replay, indeed I see a few lights appear twice,
BUT I CAN NOT REMOVE the duplicate.
I asked smartthings support for help , to no avail. they asked me to use the new app…

I hadn’t actually really looked in the old app after re-setting up lifx.

I was able to delete the duplicate old bulb in the new app - I didn’t realize that the dupes were also in the old app. I cannot delete them from there.

Please excuse me, but I don’t understand what you have meant with this.

I’m having issues with all my Lifx bulbs not working in either the Classic or new app.

I can see them in both apps. As per Gabor’s reply above, the classic app shows a new tile.

However, I can do nothing in either app and no automations work anymore.

In the Classic App - if I choose to switch the bulb off, I see ‘Turning On’ which stays like that for a few seconds and then simply goes back to ‘Off’.

If I try in the New App I get a message, “A Network or server error has occurred. Try again later”.

In the new app - all the bulbs are shown as being on - but they aren’t!

I have tried to delete Lifx and reinstall it in the new app and I still have the same errors.

What is the status of these bulbs in the LIFX app? Can you control them in that?

It happens time to time that they loose cloud connection.

Look in the app for the Cloud connection details

You can find it if you select the bulb and after the 3 dots on the top right and Light settings (gear icon) on the bottom right.

The solution if the cloud connection drops out was to turn of the bulb for a longer period and turn it on again physically at the power source.

If still no cloud connection for the bulb, then reach out to LIFX support. That happened with me recently as well. They confirmed the issue in a few hours and solved it as well.