Life360 not working for multiple individuals

I have two Life360 users in my family that I would like to connect to SmartThings as presence sensors. Both are functioning in Life360, but SmartThings is only detecting one of the two users. I have uninstalled and reinstalled the user that isn’t showing up which fixes the issue with that particular user in SmartThings, but the other user that was previously working stops working. I initially tried to set up both users on the same Life360 Connect app. Both of their names showed up when configuring the setup, but selecting both names resulted in an error. Therefore, I have downloaded a Life360 Connect (SmartThings Labs) app for each of the users (total of 2). Any ideas?

This may be related to the cloud-t-cloud issue currently happening. @Ben might be able to confirm this for Life360 as well.

Yup. This is now fixed however.

Thanks for your responses @brianlees and @Ben. So, do you recommend that I uninstall and reinstall?

Good news. SmartThings is now reporting accurately for both Life360 users. Uninstalling both Life360 Connect apps and reinstalling a single Life360 Connect app corrected the issue.

1 Like

I’m having this issue as well. I’ve tried installing one instance of the Life360 app and selecting two users but I get an error message as well. I’ve tried uninstalling and reinstalling but never works. So I had to resort to installing two instances of the app and only selecting one user in each.

Problem I’m having now though is that the presence location is only updated for one user at a time in the background. The location for the second user doesn’t update until the ST app is opened on the iPhone, it never works in the background.

Using v2 hub by the way.

Anyone else seen this?

Indeed, Life360 is not working for multiple users. After I login to Life360, even if I select both users, I only see one user. If I select one user, everything works well. The problem appears only when multiple users are selected.