Life360 not showing as a linked service

Life360 not showing as a linked service.

I used to have it as a linked service but not sure what happened and now it’s gone.

Can’t seem to get it back.

Have logged both or both of us out of both Life360 and Smartthings and back in again and still won’t show up.

Can anyone help? I’ve asked this before in other groups and just get nowhere

two thoughts come to mind…

option 1 - try installing it from IDE at https://account.smartthings.com and select SmartApps then click Add Smartapp and choose from template and find Life360 (connect)

option 2 - install the following custom smartapp

hope one of these options helps

Heya and thank you for responding.

Just a quick update before I try the second one.

I did do the first one just now and it’s showing up as a linked service but I’m unable to add it into any automation. When I click it it gives me an error that tells me to try to reinstall it. Plz see the screenshot.

When I go to smart apps It gives me the same error.

Very odd.

I’m trying to use it as a way to determine when we’ve left the house. For automations. Right now I’m using a virtual presence sensor using the iPhone.

Eeps. Is that second one webcore? I don’t use that. :frowning:

What’s wrong with Life360 and why do so many other people have it working as a linked svc? Frustrating.

with that image, i do not really have enough info to be able to respond. there was a brief outage earlier so not sure if it is related.

1 Like

it is not webcore but it is custom code for life360 that happens to work with webcore.

1 Like

I hear you. I realize it’s cryptic but that’s all it’s giving me.

If I go look at my linked services and touch on Life360 it gives me that dialog in the screenshot.

If I go to Smart apps, scroll down to Life360 to try to add it, and touch on it, it gives me that same screen.

That’s all I can tell you. Sorry. I wish I had more information because then I might be able to figure it out too LOL

I’ll have to try that other option you gave me tomorrow. I’ll let you know if it works.

Actually, I should ask you – should I get rid of what I did today first? Will that screw it up if I don’t?

Thank you again
Mel

Aha. I have zero idea what this means BUT I enabled OATH. Saw someone talking about it on the second idea link and thought I should try doing it on the first one. Works!

OK – spoke too soon. I get to the select users portion of the install within smart things and whether I pick just me or me and my partner it then crashes and gives me that same screen.

What the hell am I missing? Is there something in the code I’m supposed to be changing?

See screenshots to see where it fails.

Also I can’t understand what that other app is or how to go about installing it. Looks pretty convoluted. Don’t see anything that looks like instructions and more than one person seems to be having issues with it. :frowning:

i don’t know what to tell you at this point. it appears ST may be pushing this integration to the side in favor of the app’s location. IMO

i am not familiar with the custom app for life360 but you can post in that thread and i am sure someone will offer you assistance. :slight_smile:

If you are trying to use the life360 smart app in smartthings make sure you set up you “home” locations using a web browser. You can’t do this using the life360 mobile app. If you use the mobile app you will get an error in smartthings when trying to set it up.

Oh how I wish that worked. Sadly it did not. Same error.