Leviton Decora Wifi Devices Keep Showing Disconnected


I’ve been using ST for the past 1.5 years with ST motion sensors and Leviton Decora Wifi Dimmers and Switches without problem, until a few months back. All of my automations suddenly stopped working. Looking in the ST app, it showed al of my Leviton devices as disconnected (cloud with line through it). ST Support had me remove the Leviton service, log out of my ST account, delete the ST apps (new and classic), and reload the app and leviton service again… .AND IT WORKED! However, I had set up all of my automations from scratch again which took a couple of hours. It worked for a few weeks and then yesterday, same thing happened…none of the automations work, all of the leviton devices show a cloud with a line through it.

Help please! I don’t want to keep deleting/reloading the app and then redoing all of my auatomations from scratch. Any ideas?


I had similar issues with Leviton DZS15 switches and DZ6HD dimmers last summer.

The cure was to update the firmware on the device to 1.20. You’ll find more info if you search these forums for your Leviton model(s).

Check your firmware version and contact Leviton support.

Thanks! 95% of my switches are at 1.4.x and the others are at 1.2.x…… however ALL of my leviton devices show as disconnected. Did you have the same experience?

The ones I had issues with were at 1.1, I think.

At the time I got the 1.2 firmware bundled with the Homeseer Z-wave flash utility. It was an expensive way to do that.

Mine have been solid on 1.2