Leviton Appliance Module and Coffee Maker

Is anyone successfully controlling a coffee maker with ST? What are you using?

I bought a Leviton Z-wave appliance module to do this, and it isn’t working. The module turns on and off fine (I can hear a relay click), and if I plug a lamp into it the lamp goes on and off, but when I try to plug my coffee maker into it the coffee maker will turn on the first time, but will never turn off. The module is turning off, but the coffee maker is still getting power. I’ve checked the power rating for the coffee maker and it is well within the rated specs for the appliance module.

I’ve since read of others having similar issues with the Leviton appliance module. According to a post on the Iris forum…

"Those devices have a circuit that senses load across the switched outlet which allows the devices on/off switch to trigger the relay in the outlet. It’s a nice feature that goes back to the X10 modules that allow you to control devices without reaching to use the button on the module.

This feature works by placing a small voltage on the controlled line that’s invisible to most electronics. I say most because in your example the power to the feeder is enough to make it think that power hasn’t been lost."

Is this unique to Leviton or all Z-Wave modules?

Are there any solutions that will work with a coffee maker?

Coffee makers are tricky because the newest ones have very sophisticated electronics and are intended to go into Low Power Mode to keep the coffee warm and they often don’t work with just a simple on/off module.

There is an alternative, although it’s expensive and a little strange. But it’s designed for exactly cases like this.

There is a South Korean engineering firm which has developed a line of “micro bots” including a button pusher. This is just a tiny Actuator that can be stuck in place, but it can also be controlled to do multiple pushes, or pushes separated by pauses, all that.

The button pusher itself isn’t too bad as far as price – – it’s $49. But if you only buy the button pusher you can only control it from its own app on a nearby phone.

If you want to be able to access it is in IFT TT, which would give you smartthings integration, you have to also buy the $99 bridge, Prota. One bridge can handle several dozen Microbots.

That’s more devices and more money than most people want to spend, but it is an option when you have a device you really like but it requires a button push and it doesn’t integrate.

The devices are now available at Amazon. Some of the early reviews for the bridge were terrible because people didn’t understand what they were buying. The professional reviews have been pretty good and you can always return it if it doesn’t work.

It’s on sale right now with one bridge and three microbots for $199.


So there is an alternative, although I don’t know if it’s one you would be interested in. I myself am quadriparetic with limited hand control, so this kind of device has several use cases at my house. :sunglasses: I don’t have the Prota yet, but it’s on my wish list and I’m pretty sure I’m getting the starter kit from my family so I’ll be able to post a personal review in January.



I should have mentioned that this is a simple coffee maker with a mechanical on/off switch, no timers, soft buttons, etc. It worked fine with my old X10 appliance module. I just leave the coffee maker switch in the on position.

As a test I took the GE outdoor switch that I bought for the Christmas lights and tried that, and it worked perfectly. I ordered a GE appliance module with same day delivery on Amazon so I’ll test that later. The Leviton module has been relegated to Christmas tree duty and is working fine there :slight_smile:

1 Like