LED on/off on GE switches

I just purchased and installed a Smartthings Hub 3rd gen. And using the new smartthings app.
It’s been great!

I am installing GE zwave switches. After installation and pairing, the blue LED changes … before pairing the LED was on when the light switch was off. Now the LED is on when the light/switch is on. I am okay with this as long as they are all the same.

Just put in a dimmer switch which shares the electrical box with a fan switch so I put in a GE fan switch as well. This switch is opposite with the LED … the LED is on when the fan is off and the LED is off when the fan is on. Opposite of the switch it is sitting next to.

Any idea why this is? And how to change? I am not using Smarrthings classic but I do have access to the groovy ide.


1 Like


In the classic app, for the device there is a setting to set the led behavior. Set it and save it.

Click on the gear in the device view in the classic app.

There is a setting led indicator


You need to if you want to manage other settings and capabilities (like LED behavior) the new app isn’t able to do yet.


If I change it in the classic app, will it “stick” in the new app? I assume yes …

1 Like

The setting updates the device itself.

1 Like

Sure does. As soon as you tap on Save.

Also, just an FYI on the Fan Controller LED:

(Note, the app in the link below doesn’t work anymore - just providing the link to explain the issue with the LED).

There is a series of taps of the switches that change the behavior on the fan switches. Hopefully it’s in the link Nezmo provided. Something like 5 times rapidly.

Was able to change the switches with the classic app.
Can’t change the fan though …

You have to follow the instructions in here:


Well that worked , On On On Off changes the fan led

All is good!


1 Like

Thank you!! This worked perfectly for me. The odd thing is the classic app showed the LED state to be on when the switch was off but it was behaving opposite. I just hit save and they work properly.

Just thought I would share what worked for me. I was also observing that the LED on the switch was inconsistent. I went into the app, navigated to the switch, selected the LED state (“when off”) and then selected done, then save. This seemed to resolve the issue.

The value defaults to “when off” but somehow explicitly setting the value in smartthings seems to help keep it in sync.

Were you able to set the LED in the New SmartThings App or are you using the Classic App?

The led can.be changed in the new app.

I set it in the classic app. I see it now in the new app as well, though it doesn’t appear to let me do anything.

Hit the 3 dots on top.right hand corner & hit settings. You will see “led aettings” on left rop side.