GE / Jasco Z-Wave Fan Speed Control 14287 Notification light won't turn off

Hey Folks!

I have been beating my head against the wall trying to get the blue notification light turned off on the new 14287 fan controllers. All the custom device handlers (6 or 7 that I’ve found) and a smartapps I found here in the forum don’t seem to work on the new plus version of the switch. The only comment I’ve seen is that it’s bad firmware on the physical switch and I’m screwed.

It’s tough to believe that GE/Jasco has sent out two generations of fan controllers that have bad code for the notification light. I also can’t seem to find any way to “update” the firmware on the switches.

Has anyone been able to get them to respond to the Smartthings zwave command?

GE Z-Wave Plus Wireless Smart Fan Speed Control, 3-Speed, In-Wall 14287

Thanks everyone!

-John

2 Likes

You can adjust it from the switch itself. Quickly tap the following:
ON ON ON OFF

6 Likes

OMG. Go @bradlee_s!!! That is amazing. I’ve been trying to get mine to change forever and couldn’t figure it out. I will add one caveat…the switch has to be on before you tap that sequence to turn it to indicate when the fan is on rather than off. And it still blinks when setting the speed. That’s awesome!!!

But yes, you are right @JohnnyBoyGee, none of the DTHs for this switch can change that setting for some reason.

1 Like

Thank you so much! I had given up on this and the device handler author fixing it. Glad there is another way.

1 Like

In my case, the fan does not have to be ON to perform the sequence and change the setting.

@bradlee_s Thank you so much! Glad it’s helping others as well already!

1 Like

Same with mine. In fact, I think it had to be Off in order for it to accept the change.

Unfortunately doesn’t work on mine. Tried it both ways, with fan on and with fan off. No change.
And it sucks because on the GE Light Switch it is sitting right next to, I have that set in the DTH for Indicator On when turned on, light off when turned off.
Its difficult when trying to teach the family and saying “well, when this blue light is on then the lights are on. Except for this one, if the blue light is on then the fan is off.”
I know the responses–just make the light switch match the fan switch. But the point is I don’t want the blue light on when the switch is off.

You have to do this very fast. It works on all of my GE dimmers/fan controls.

What model are you using?

Model 14287.
Didn’t think I could do ON ON ON OFF any faster until I figured out that using only 1 hand wasn’t cutting it. Still, took about 2-3 tries to get it on the one fan but now that I know it was “slow hand error” I’ll do it in the kids rooms tomorrow.
Thank you for the extra help.

what device handler are you guys using for your 14287?

Ping. I want to know what device handler you are all using too. I’ve been using one custom from jscgs350 : GE Fan Control Switch, but it has one quirk: claims speed is high no matter what the setting on the ST app. I’m wondering if there’s a better one out there yet?

Okay, I found that if I just explicitly set the low, medium, high settings to 30, 65, 99 in my case, it shows up as low, medium, or high properly. So no need to change my handler after all. But still interested if you all found a better one for whatever reason.

One odd observation: I see my one fan on the same circuit will be at medium speed if I set medium to 67, while the other is clearly on high at 67. Hence why I backed off the settings slightly, 30 instead of 33 for low, 65 instead of 67 for medium. Now the two fans match at low, medium, high.

1 Like

this is the repo for the one I am using, working great for me.
Owner: constjs
Name: jcdevhandlers
Branch: Main

Are there any other sequences? ON ON ON OFF seems to toggle between the blue light being on when the fan is on and being on when the fan is off. How do I set it so the blue light is always off?

With a dab of nail polish :slight_smile:

1 Like

I have been trying to get the ON ON ON OFF trick to work. It doesn’t seem to take, so I am thinking maybe I am using the wrong device handler. Which device handler is being used where we know this combination of taps works?

A different DH will never fix this.

So I tried the combo again and it worked. I guess I wasn’t doing it fast enough.

1 Like

I can get mine to toggle between blue light always off & blue light on when on / of when off. I want to get to off when on and on when off.
Ideas ?