LED Indicator settings field disappeared

Was just wondering if anybody else had this happen to them?

LED indicator was not coming on when lights were off as programmed.

Went into settings for that device and lo and behold there was no field present to reset the LED indicator to select on when lights off. Was gone! Just like the turkey that the Bumpus hounds ate at Ralphy’s house!:joy:

GE smart dimmer switch about 18 months old.

Thanks for any info in advance. Hapster.

Have you changed the device handler at all?

Literally just installed a couple Z wave and Z wave plus GE devices along with renaming some old devices today. Everything is using the standard generic dimmer switch DTH and every one of them had the LED indicator field on them.

As @Automated_House said check the DTH you are using and if its custom try switching to the standard dimmer switch one.

I’ve heard the term device handler many times now, but I have no clue what it means or how to do this. Any info on this would be greatly appreciated. Thank you.

It’s basically the code that’s handles commands to and from your device. Since you aren’t familiar, I’m guessing you haven’t messed with it :slight_smile: The easiest thing to do would be to email support and see what they say support@smartthings.com The quickest would be to login to https://account.smartthings.com do to your devices tab, click on the device and see what the “type” is set to.

Thx Jimmy. Yes I’ve left everything standard and think that’s best for me as I would make more problems for myself not being software savvy. Thank you for the input I appreciate it!

Hope you’re having a blessed holiday!


Building on what Jimmy said log into https://account.smartthings.com then go to the “My Devices” tab. Find one of the devices you are having a problem with and click it. It will pull up lots of details. At the bottom click the “Edit” button and under “Type” switch it from “Dimmer Switch” to say “Fibaro Dimmer” then click “Update”. It will say the device has been updated. Click “Edit” again and switch it back to “Dimmer Switch” and “Update” again. Check the device in the app and see if you now have the option to set the “LED Indicator”.

If not contact support.

Got it! I have been to that area of STs before and will follow your direction. Makes sense to try and “reset” it back to its factory default setting. So far this has been the only glitch I’ve had knock wood! It’s been pretty steady for us. I’ve not strayed off the “standard” path and feel more comfortable with that approach. If this doesn’t do the trick I’ll just change out the switch out.

Thank you for the added input vseven! Your steps were pretty easy to follow knowing the screens your referring to.

Thx again.


Try it and let us know. Like I said if that doesn’t work contact support…they can verify its correct on their side before you swap out the switch.

Yes, support may be able to help w/o a dimmer switch change out. That would awesome too!

Thank you for that!


I will keep yas posted! Thx

Sounds like the DTH was changed to Z-Wave Dimmer Generic, which does not support the indicator capability. Try changing it to Z-Wave Dimmer. I have no idea how it could have been changed in the first place but that change should fix it up nicely.

Thank you for the advice and info Steve. My dimmer is in fact a GE Zigbee in wall dimmer. This information shows up internally when I go to the graph.api site. My initial finding was that it was set as type Zigbee Dimmer Power. I’ve switched it several times to different types and then back with no luck. I believe the type is set where needs to be as the three other Zigbee Dimmers are set the same.

I have just discovered with a little investigation that all my Zigbee Dimmers no longer have the LED control field in the settings menu. This is something new, because I recall initially setting each and every dimmer, whether it was Z wave or Zigbee to have the LED indicator on when the lights are off. Each LED indicator on all dimmer switches are working as initially set up with the exception of the one Zigbee Dimmer. It’s LED does not work weather the light is on or off and all Zigbees no longer have LED control field? But their LEDs are still working fine. Very puzzling? I would have never noticed the loss of the LED control field in settings, unless the one LED had not gone out!

To everyone else that offered advice, Vseven, Jim, thank you very much. I’m still open for ideas after having reported back to you all. Could it have been an update that cancelled that field from the Zigbee devices?


Sounds like SmartThings May have updated the device handler and removed the function.

This might have happened with the 19.17 firmware?

@tpmanley - Was there something done in the GE ZigBee Dimmer DTH that would have removed the LED indicator functionallity when using the stock DTH? I see it on the list for the 19.17 firmware update.

Nothing was changed in the DTH to support the 19.17 release. I could be wrong but unlike the Z-Wave DTH I don’t think the Zigbee DTH ever had support for configuring the LED indicator, or at least I don’t see it in the git history. I’m not even sure how it can be done over the Zigbee network. However the manual does describe how to change the setting manually:

To turn LED off/restore LED:
Tap top rocker (ON Switch) 3x quickly and then tap bottom rocker (OFF Switch) 1x.
Follow the same series of button presses used to disable the LED to restore

1 Like

Tom and Alan,

Thank you so much for looking into this for me! I tried the manual reset
and it did in fact work!

I do not recall setting up the other Zigbees using this method and can only
remember using the LED configuration field in the settings for each
dimmer? Oh well. You guys figured it out. Thank you for your help! Many
blessings to you both in 2018!


1 Like