Leak detected, turn off a/c

I have flood sensors near my two a/c units. I have them set to alert me via the default SmartApp but I’d also like to turn off the source of the problem. My a/c units are controlled by ecobee 3 thermostats which are also added to my ST hub. This seems like something that should be possible out of the box but I can’t figure it out. Any advice is welcome. And apologies if this has already been explained elsewhere, I can’t seem to find it.

I don’t see a stock app option either. But you should be able to do this with CORE.

I recently had an AC leak happen to me. Very frustrating since I have a ton of moisture sensors and a smart valve only to have a leak unrelated to plumbing. Custom leak monitoring for non plumbing issues should be added to SHM - and they should add thermostat changes as well.

I ordered more moisture sensors for my AC unit recently and will set something up in CORE unless you find a stock option I didn’t see.

What is CORE ? First time I am hearing the term. Guess I missed something…

it is Beta - but still effective for me

Community Beta is better then ST production any day :slight_smile: I have to give this a try.


Thanks. I’ll give CORE a shot. I’m new to all of this. Just got my hub setup earlier this week. I had a similar thing happen with my a/c recently when the drain pipe backed up and filled up the water pan in the attic. The float switch worked but only after the A/C fan motor fried itself :frowning:

I’ll update this when/if I get it working.

Mine was a cracked drain pan - so the water wasn’t getting to the drain pipe. Unfortunately I don’t have a pan under the whole unit. There is a whole CoRE thread where you can get help setting up pistons if you need help. Or I can post a piston here once I make it if you still need help.

This seems to be working! I got it all setup at least and CoRE is very cool. Thanks again! Now to learn Groovy :slight_smile:


I had an HVAC guy out yesterday to fix my float cutoff for my Attic furnace catch pan.

I decided that I want to get alerted sooner than a full pan. I added turn off HVAC on leak to Nest-Manager Automations in the next release. I know this doesn’t help Ecobee people, but if a Nest person stumbles on the thread, it is built into the App.

Thanks for the idea and the timing of the post was coincidentally timed to when I discovered my float was not working.

I have the same problem as well, and webcore is no help at all, its greek to me. anyone have any other solutions?