Latest iOS SmartThings (1.6.27) - Missing Modes

I have 4 modes in graph.api, but only 3 in the latest version of the app.

In my automations, the modes all show, but don’t seem to be used.

When I add new modes, they don’t appear in the app either.

This is one of my primary modes that turns off all the sensors when I’m home.

I had to turn most of my automations off because I was constantly getting notifications walking around my house.

The three dots on the top right>manage home>modes. Then scroll thorough them. It looks like it doesn’t add because the window only shows three modes at a time but also doesn’t show a scroll bar so it’s confusing.

I don’t understand the issue. Automation triggers aren’t changing modes?

It’s hard to tell, but the mode box scrolls.

You guys are right. Thanks. That’s bad UI.

Now I’m just back to my earlier problem of modes not changing based on location. This started with the new SmartThings when I started using it a few weeks ago.

I haven’t had luck with iOS mobile presence with the new app. It keeps turning itself off.

For me it occasionally works, but is essentially useless. I actually bought a button to press and double-press when I come and go.

I’ve gotten presence to work in the new app (haven’t done too much with it), but it’s either working in the new app OR the classic app. If presence works in the classic app, it doesn’t work in the new app. I’m iOS, so for now, I’ve disabled the location permission for the new app because I need presence to work in the classic app for SHM.

What I found was that going back and forth between the apps on the same device just seems to get it all mixed up, and then, nothing works. I use the new app on my iPad for configuration, and I have the classic app on my phone for presence and those rare times that I have to get in the app and press a button. That seems to be the best mix I’ve been able to make work for now.