Kwikset locks don't pair correctly

I have 2 “dumb” kwikset 913 locks that I bought a long time ago. I recently bought “Home Connect Lock Module, Rf Z-Wave Plus 500 Series Chip REV 3.8 for Kwikset Models 909, 910, 911, 912, 913, 914 (Z-Wave Plus)” to be able to control them with Smartthings. Although they will pair I am seeing wrong status, inability to control the locks, and in the IDE " ZWAVE_S0_FAILED". I have tried excluding and adding them back in. I am pairing within a foot of the v2 hub. I have tried having the locks both locked and unlocked while pairing. I tried a support ticket but they ended up saying it’s not tested device and maybe the community can help. Oddly I have a v1 hub at another location on the same account and I am able to successfully pair with that hub. Anyone have this working and if so do you have any suggestions? I don’t have any custom lock device handlers.

You might want to contact support

Try this:

  1. Exclude the lock
  2. Reset the lock (refer to manual)
  3. Reboot the hub (important step)
  4. Pair the lock

Also check if you have any custom device handlers which may have gone stale and causing an issue (FAQ: My lock/device does not pair or appears to pair but it won't show up in the mobile app or IDE - stale DTH)

Thanks for this. I tried and still no luck :frowning:

This thread about Smoke sensors says “Did you get a secure inclusion for these. i.e. zw:Ls at the beginning of the raw description for the device in the IDE?”

I don’t know if that’s specific to smoke sensors but my raw description for the lock looks like this:

zw:F type:4003 mfr:0090 prod:0003 model:0436 ver:0.00 zwv:0.00 lib:00 cc:5E,72,5A,98,73,7A role:07 ff:8300 ui:8300

Does anyone know if this is an issue?

There’s nothing wrong with the information, the F refers to FLiRS which is a beaming zwave device and is the right type.

Your information looks good. If the rebooting the hub didn’t help but it’s working with the other hub then I suspect it’s a hub chip issue or a network issue (latency). Try to reboot your router and see if that helps or move the hub to a different port if possible on your router.

If it still fails maybe @Kianoosh_Karami could provide additional troubleshooting steps.

I’ve never seen that suggestion before. What does that do?

In our lab we once had an issue where the hub had pairing issues and kept acting up with connection issues. The second hub right next to it was just fine. Finally decided to move it to a different port and it started working fine.

Couple have been a bad connection or a bad Ethernet wire (we also changed the wire) or a bad port.

1 Like

I gave up and returned the modules. I ordered some zwave (not plus) ones off of eBay for half the price. I have my fingers crossed. Thanks for the help.