Kwikset Locks battery life warning


(Matt Fink) #1

Hey All,

I have two kwikset locks - one is a 914 and the other is a 916. They work great with Smartthings (v2) accept one thing… I don’t get a battery level from them. Do I have to change/add something to get that? Ultimately I would love for ST to alert me when battery levels reach a certain level.

Thanks!


(Bobby) #2

Working with support for the same issue. I have 2 x 914 that don’t report the battery level. Open a ticket, because the tech guy said “no one else complained” so it must be something with your locks…:frowning:

One thing they’ve suggested yesterday was to take the battery pack out and put it back in to see if that fixes it. I am going to try that right now :smile:


(Matt Fink) #3

yeah I will def write them - till working with them on getting Hue’s to work with V2.

I never realized with V1 I didn’t have battery level until one night over the summer I was working late (out of state) and my wife got locked out because the battery died…and she forgot to put the spare key back…that was a very expensive mistake haha


Kwikset 914 zwave not reporting battery level
(Bobby) #4

Really, you didn’t have the battery indicator working with v1? Mine was showing the levels on both locks with v1


(Matt Fink) #5

I thought it was…then it wasn’t haha!


(Bobby) #6

You may want to take a look at this thread…


(Kurt Sanders) #7

I waited about 7 days after the V2 migration and finally my Kwikset 916 reported a abttery status of 100%. I don’t believe it, but it’s better value than than a dash… I think that I also cursed, cussed, hit refresh 10 times a day, sweared and prayed for a battery status… One of these works.


(Bobby) #8

On the other hand…removing the batteries may solve the problem! I have two locks and “treated” both with resets, z-wave exclusions/inclusions, curses and swears but I only removed the battery pack on the one that is now showing the battery level…so.


(Matt Fink) #9

My 914 finally started working but my 916 still has the dashes - I checked device type to see any difference and nothing - both listed as z-wave lock… any suggestions on switches to make in the IDE?

Also is there an app to warn about battery level?

Thanks guys!


(Bobby) #10

Follow the link above to get a custom device type and a super nice app. Just installed both and they are awesome, both by @ethayer.
Also, search the forum for an app by @notoriousbdg called BatteryMonitor. Works well for me - I had to do very minor changes to make it work the way I wanted.