Kwikset 914(?) pairs but doesn't work

So I inherited what, I believe, is a Kwikset 914 lock (model # 450191) when I bought this house – it was part of the previous owner’s Vivint security system. I was excited to get it working with SmartThings, but I have never been able to get it working. I eventually bought 910 that has been working flawlessly, but I would LOVE to get this working and be able to control the back door as well.

Here’s what’s happening. I can get it to pair with SmartThings with no issue. It shows up in the list and everything looks like it should just work. BUT, when I try and send any command to the lock it does nothing. The app shows the gray “Locking…” indicator, but it just sits there. The LED on the lock lights up like it’s receiving the signal, but nothing is actuated.

I’ve replaced the batteries, reset the device, tried pairing at extremely close distances (i.e. the lock was sitting directly on top of the hub). I’ve tried a wide variety of device handlers, including ethayer’s Lock Manager Smart App, but nothing seems to work.

I’m wondering if there’s something I’m missing or if I finally just need to toss it. It’s just so weird that everything seems like it’s “talking” but no commands are ever carried out.