Jawbone UP24 Sleepy Time issues with Android


(Jake) #1

I am having an issue with the sleepy time app for jawbone up24 on my android phone. I am not able to set it. My jawbone connects to smartthings okay and I am able to set up the step notifier app. However, when I try to setup the sleepy time app, I select my jawbone, my phrase for going to bed and waking up, then select done and nothing happens. It doesn’t show up in my smartthings labs category and I am not able to use it because it’s not there. If it helps I have a samsung galaxy s4. Thanks in advance for your help!


(An) #2

I had the same issue on a HTC One M7 running Android 4.4.2. I had to setup the sleepy time app on my iPad, but the band is still connected on my Android phone. Unfortunately, SmartThings still doesn’t detect what mode I have the band in.


(Jake) #3

I mentioned something to Juan Pablo Risso, the developer working on up24 integration, on this page: http://blog.smartthings.com/news/roundups/meet-smartthings-developer-juan-pablo-risso/. Hopefully he sees it and helps out!


(Juan Risso) #4

Hi! it seams that there is a problem with the Android app that SmartThings is aware of and they might need to fix it.
Here is an other thread talking about some of the issues:


(Jake) #5

Good to know, thank you very much @juano2310 !!


(Jake) #6

@amn0408 @juano2310 unfortunately the latest Android updates haven’t fixed the Sleepy Time issues, but I wanted to share what I found works in case others might benefit. I was able to use the button controller smartapp twice, one for the good night action and one for the good morning action, to accomplish the same thing as sleepy time. I can vouch that it works very well… the only issue I’ve found is if I get up in the middle of the night and walk around, it will set my up24 to awake mode and turn my bedroom lights on as if it’s morning and wake my wife up. I thought she was going to kill me one night! It’s an easy workaround though… I just take my up24 off if I wake up in the middle of the night before I get up and move around.


(An) #7

Thanks @jdrorrer! I just started using the button controller. Works quite well. I got around the middle of night issues by limiting the hours the good morning and good night action can happen.


(Jake) #8

That’s perfect @amn0408! I was so excited to get it working that I looked past setting a time window… Lol thanks!


(DLee) #9

Any word on a fix for Sleepy Time app not working? I see step count just fine so that issue looks fixed for Android, but the Sleepy Time App still doesn’t do anything. I tested tonight. Having Sleep and Wake up modes control my Goodnight and Good Morning actions would be way more useful than what the single long press button controller workaround offers.


(Chaosrain) #10

Nearly a month after Dlee’s post. Still can’t get anything to happen when engaging the Sleepy Time app. I get that it’s a Labs app, but there’s no point in posting an app that doesn’t do anything.


(DLee) #11

@Ben who told me to always type @Ben we want him to see something. :smile:


#12

Any resolution? I still cannot get ST to read my UP24 w Sleepy Time.

Thanks


(Juan Risso) #13

The solution has been submitted and it is been tested. As soon as it is approved it will be published :slight_smile:


(Brad B.) #14

Joining the club here… I can setup SleepyTime but it never appears in SmartApps for the Up24.