Jasco Zwave Switch "Double Tap" Problems

Hey all, I’m trying to write a piece of software to allow me to tap a switch multiple times and fire different hue presets. Unfortunately after my Jasco switch is in a state (on or off) pressing the switch in that direction no longer triggers an event. I’ve scrubbed through the forums and haven’t been able to find anything that really explains how others have made their double-tap apps work.

A little background, I’m using each tap as an event trigger with a state variable tracking how many times the switch has been pressed (to allow for tracking across events from other apps, it’s more of a hue preset state than a tap state). I’ve tried installing the Double Tap demo app to test tapping functionality and I can’t get that to work either.

I’ve also checked the logs and tried tapping multiple times with spacing varying from miliseconds to minutes. Anyone have any thoughts on workarounds? Or is there a brand switch that works better in this department?


My double taps haven’t worked for a couple of days.

Anyone else have this issue?

My double tap works, but double tap on triggers another switch on and doubletap off triggers another switch off.

My understanding is that double taps only work if you are directly communicating with the Hub… NOT through the mesh network. Is it possible you’re too far from the Hub?

The switch is about 10 feet from the Hub. I also believe it is currently the only device acting as a repeater (part of the mesh). All my Hue bulbs connect to the Hue Hub so they wouldn’t act as a repeater unless I’m misunderstanding how universal the mesh is. Is there a way to check this?

Did you ever figure this out? I’m trying the same thing but haven’t had any luck so far.

I set up the double tap app for my Jasco Zwave switch (the newer one with a neutral) and couldn’t get it to recognize the double tap was anything. I counted like above. Any other ideas?

Im using a bunch of Jasco/GE Z-Wave On/Off Relay Switch Model 45609 and double tap has always worked well.


Anyone have any luck on the double tap “on” to work on the GE dimmer 12724

My jadco/ge switches have always worked well, but never had a dimmer or aux 3-way switches work. After v2 migration now fires mostly on single tap anb off on 3 or 4 taps.


Removed all DoubleTap smartapps and readded, same issue. So, I thought till the system settles down, I’ll just set them to only double tap off, unfortunately that function don’t work for any of my switches at all (no response at all), also either does the “Only On”, strange…

Set back to On and Off and still have the intermittent ons with single taps and slugglish offs (3-4 taps) on all 4 of my double taps setup on 4 diff switches (none overlapping)…