Jasco 45609 Switch


#1

One of my 2 Jasco switches stopped responding to app commands consistently or if it does only for a short period of time. ST support updated my firmware for this switch and I reset with the air gap switch but it only worked for about a day. Is this a common thing with the Jasco switches and are there any other workarounds to this? ST support blames the switch’s firmware.

I have my hub on top of a counter in the 2nd floor loft and has a fairly unobstructive line of sight to the switch in the downstairs kitchen which controls my outdoor light. My other switch is in the garage and seems to have no range issues whatsoever. Last week both switches worked flawlessly on the Wink hub prior to switching to ST. Not a big fan of Wink’s glitchy software so I made the jump to ST.

Also, are there other more reliable Z Wave in wall switches at the same price point as Jasco/GE?


Ge dimmers not working
#2

I have almost 40 of those switches, plus a handful of GE dimmers, and so far I haven’t had a switch die or needing replaced. My zwave mesh is spread out enough where I do not have large gaps in coverage, so maybe you should consider adding another powered zwave device to build yours out more? Sounds like you should be OK though.

I have had a couple just “forget” being in a network, but pulling the air gap switch or tripping the breaker did the trick every time.

As for price point, not really especially if you get them from Lowes.


#3

I have one ST support person via email thinks it’s a polling issue caused by the switch’s firmware and doesn’t think it’s a range problem. And the other ST support person via chat, thinks it’s a range issue. She tried repairing the z wave network and would get this error message: “Network repair for Rear Outdoor Switch [16]: Failed to update mesh info” and “Failed to update route.”


#4

OK, that info is helpful. You should try a repair one more time, maybe twice, and if those messages still persist you’ll need to exclude the switch and add it back. I had the exact same problem about 3 weeks ago with one switch and excluding and re-including it resolved those messages.


(Michael Scragg) #5

I just installed a Jasco 45709 switch. (I suppose it’s a newer model) It’s my first switch outside of a dimmer of the same brand, so treat me like a newbie. My question is, should there be a nearly one second delay on the light turning on/off even through physical contact with the switch? I also hear a click when the light goes on/off, I’m guessing that’s the load relay. Is this all normal operation or did I perhaps wire something wrong?


(Beckwith) #6

If the light goes on and off I can’t see that you could have made a mistake. My switch has about an eighth of a second delay and yes the click is the load relay. Are you sure what you are switching doesn’t have the delay?

Over time this click has annoyed me. I prefer the silence of my Enerwave dimmer switches:


(Beckwith) #7

Oops. 45709 is their newest model:


I wouldn’t doubt they added additional protective logic in the switch which delays the load switching.

Anyone have experience with this specific model?


(Michael Scragg) #8

I replaced a single pole light switch that was instant.


(Chrisb) #9

@BOLISARIO,

I’ve had one of my GE/Jasco devices stop responding. I was able to “wake up” the device by turning off power at the breaker box. Then turning it back on.

The Air Gap, to the best of my knowledge, does not completely power down the device. Try flipping the breaker to this device and see if that helps.


#10

Thanks for the help guys. It definitely was a range issue. I had to move my hub to the first floor, luckily I have an ethernet port pre-wired in my living room area. All’s well so far, but I did add a repeater just in case and plan to expand my z wave mesh.