I've got zigbee HA-supported devices that don't seem to want to work. Help?


(Chris Sanner) #1

Are there any power users out there who can help me troubleshoot these things?
They appear to be presence sensors - some SNC and some visonic.
All the documentation I’ve found suggests they should be relatively trivial to connect and use but nothing I’ve tried works. The hub sees them and adds them as “Thing”, detected device type “unknown” - the PDFs I’ve found say that they’re Zigbee Home Automation Profile Compatible, so I’ve tried the various options and get back nothing.
What can I do to troubleshoot this?


(Scott G) #2

Can you provide more info or links to the particular sensors? I don’t see that visonic makes any presence sensors, but maybe motion sensors?

If there’s any documentation to tell us what clusters it uses and/or at least what device type it really is we can hopefully get some communication going with it.


(John Rucker) #3

When devices join the SmartThings hub they often show up in the Hub’s log. I have been able to find the device’s supported clusters and end points in this log. Just a thought if the documentation doesn’t have it.

If you can make the device do a ZigBee device announce that also triggers the SmartThings discovery process and will case the clusters and endpoints to be logged.

I have found it difficult to write a custom device types without the device in hand. Good luck Scott I look forward to watching your success as I’m pretty much burned out on SmartThings these days.


(Chris Sanner) #4

sorry, it was late and I was fuzzy-brained - open/close door sensors.
let’s focus on the smc one as that’s the one I can find the most documentation about
http://na.smc.com/wp-content/uploads/2011/03/SMCDW01-Z-Ruby-Door-+-Window-Sensor-Feature-Sheet-Office.pdf


(Chris Sanner) #5

I see nothing in the hub’s log at all. clearly it’s seeing something or it wouldn’t even go “hey, a thing!”. it’s infuriating not to be able to use something as simple as tcpdump on this…
I’m happy to write my own device type…I just don’t know where to start


#6

I don’t see Zigbee on their list of certifications (per their website), and they only mention they comply to a 2.4 GHz IEEE 802.15.4 standard for their SMCDW02-Z sensor, but their PDF does mention Zigbee. The sensor model referenced in that PDF is from 2011, so it may be quite old. It may be that these devices only pair and work with their RB series touchscreens and supported systems? It also looks like they’re marketed towards cable operators and additional services they could provide vs the DIY’er market.

EDIT:

Looks like there’s a thread on this already, and perhaps these sensors (used by Xfinity Home and Time Worthless IntelligentHome) may be using their own version of an HA profile like Lowe’s?

More info: http://www.openhome.io/deviceDetails?productId=41 (battery life is impressive - 9.1 yrs!)

And, http://www.openhome.io/device?categoryId=50

Lastly, anyone notice the app CentraLite is using here (hint hint, about half way down):

http://www.centralite.com/index.php/products/3-series/3-series-door-window-sensor/


(John Rucker) #7

Yea I have seen that happen as well. A device joins but there is nothing logged in the hub log. In fact I have seen the same device join with nothing logged and then reset it to factory and join a second time and then it is logged. I would suggest trying it multiple times and maybe try joining a known good device to make sure it gets logged.

If you really have to get this working you may want to look into a ZigBee sniffer, free-scale makes one and it has a USB dongle that allows you to watch the traffic of your ZigBee network. Another thing to consider is if this device doesn’t use public clusters and device types you are going to need their documentation in order to figure out how to control the device. It is possible to create a device that uses ZigBee to communicate but doesn’t adhere to public profiles and clusters. Many of the older devices do this. So you may go to the expense of buying a sniffer only to find out you cant communicate with it anyway.


(Chris Sanner) #8

it’s not so much about “have to” as it is “I’ve got a half dozen of this type of thing lying around and I’d really rather not see them go to waste”


(Scott G) #9

This is really good advice from both @johnconstantelo and @JohnR. I would echo the suggestion to try unpairing/deleting the device and repairing after a factory reset with the device very close to the hub. I tend to get better connection info when close to the hub. Hopefully that would show some information in the log to get us started. All the documentation I could find suggests it should work with the generic Open/Closed Sensor device type.

You could try adding some debugging code to that device type to see if any communication is happening. Add space between line 30 and 31 to add in the below. The current parse() is only looking for a very specific communication, so this might let us see if anything else is happening.

log.trace description 
def msg = zigbee.parse(description)
log.trace msg