Issues with Hue (Echo and SmartThings)


(John Essey) #1

Hey… just curious if anyone else is having problems controlling Hue devices with SmartThings and Amazon Echo? I dont think it’s a SmartThings issue, since I have the same inability to control from Amazon…just phishing for others having similar issues.

Thanks!


(Chris Means) #2

My setup is working fine for the most part. Sometimes I get a message about “that device doesn’t support that operation” (or something like that), but its still performed the requested operation correctly :slight_smile:

I don’t have the Echo talk to Hue devices directly, it’s all done through the ST hub.

What particular problem are you having?

Keep in mind that there are “performance” and other issues at the moment with the ST hub (though they may be mostly cloud related, they might be causing you issues as well).


(John Essey) #3

Hey Chris,

I’m unable to control any of my Hue devices via SmartThings. When I dug around in the IDE, it appears commands are being sent fine, no obvious errors – the devices simply do not function (on/off, colors, etc.).

The issue I have using ST is similar to the issues I’m having using Echo. There are a few exceptions though. For example, grouped OFF commands work, but not group ON commands. I can tell Echo to turn off the lights in a particular room (each room has 1 Hue light) and all the light shut off – but I cant use the group or the device to set the state to ON (or levels) using Echo.

This morning I tested changes to the Hue lights using IFTTT to Echo, and at least in my first test (trigger blue lights) that worked. I need to test more…

I am able to send commands directly to the Hue on my Lan via Tasker (and AutoHue plugin), and I can control the lights just fine using the Hue app. I’ve rebooted the Hue Hub, no changes. I need to reboot my routers, which I’ll do later when no one is home.

None of my issues make sense, since I would suspect if I cant control the Hue lights from ST or Amazon, that IFTTT would not work – but that isnt the case. Regarding ST cloud to cloud issues, my other cloud to cloud devices are working fine. It’s just the control of ST > Hue that’s broken (and Echo to Hue to some degree). My Hue IP hasnt changed, and I think I last did a firmware update on the Hue last month (no issues after that). I’m on v1 Hue Hub, not sure if that matters.

After I do a bit more troubleshooting, I may hard reset the Hue and try to get it back to the state I had 2 days ago (everything working, etc.).

I would like to see a bit more logging from the Hue, specifically what is happening when devices send data to it, but I dont know any tools to help with that. Short of sniffing traffic on the Lan, I’m not sure what else I can do to work on my issue.

Any thoughts and steps … I’m all ears!

Thanks!


(Chris Means) #4

I’m not having any problems like that…I am on ST Hub v2 (not sure which version of the Hue hub, but I only purchased mine about a month ago), and I’m using the Hue Connect SmartApp…can’t say if either of those are what’s making the difference.

You could try a tool like WireShark to inspect all network traffic, that might help fill the gaps for the communication between the Echo and the ST hub (which I assume is occurring locally, but I guess could be cloud based).

I assume you have checked the list of items in the Alexa/Settings/Connected Home section to make sure there are no conflicts with device names etc. though that wouldn’t explain being able to turn things on and not off.

Sorry I can’t be more help.


(Richard Peterson) #5

I am also having issues with my Hue.

From what its looks like so far is that somehow smartthings is now not registering my Hue with the Smartthings system. I havent had much time to play with it yet as I have had a busy week, but while trying to redo my Hue Connect in Smartthings Android app, it cannot find my Hue Hub for some reason. Going to look into it further this evening


(Chris Means) #6

In case you’re not already, I would recommend assigning a static IP to your hubs, rather than relying on DHCP to assign an IP (and possibly a different one when devices are rebooted). When using DHCP, your router may assign a different IP address to devices, which makes them effectively disappear when you use references to specific IPs in other tools/apps.


(John Essey) #7

Just a follow-up here…

I was able to fix my issue. I had to remove and re-add the Hue Bridge. However, in the newer Mobile App (I’m on Android) I no longer have the ability to view any of my custom SmartApps (I get an error, case opened with support and no solution offered). I had to install an older version of the ST app, then remove and re-add my Hue hub… worked fine after that.

Part of my issue troubleshooting and dealing with this is that I no longer had access to view/configure any smartApps on the new Android version, and I just overlooked that entirely. Looks like I’m keeping the older version installed on my tablet for a bit longer…