Issues with computer connecting to SmartThings mesh

Hey, I’m new to the mesh WiFi system and bought a SmartThings mesh last week.
My computer, an HP running windows 10, is having issues with it. I am able to connect to the mesh but it doesn’t not allow internet access. It worked for the first week and now it does not. The occasional times it has worked stop when I move to another area of the house where it jumps onto another hub. On chrome it will say either no internet or error network changed. All my other devices work fine. I’ve run diagnostics which sees a problem and resets the wireless adapter or access point. Doesn’t help. I’ve reset IP.

Basically, every time my computer moves positions to another area of the house and connects to a different hub it completely drops everything and can’t do it

Any help would be appreciated.

Welcome to the community Oakley50! Does this issue occur with just your laptop? Does your cell phone or other wifi devices exhibit the same behavior? If not, it could be the network config on the laptop. If you already did the ‘forget this network’ and rejoined then I would suggest rebooting the ‘main’ smartthings hub. If you’re not sure which one is the main one, just reboot all the ST hubs.

1 Like

Thank you for your response. It is just my laptop. I rebooted everything. I went out and bought a WiFi USB adapter and connected my laptop through that and it worked for a day but then started doing the same thing again. So it seems like it’s a laptop problem. I completely reset the laptop back to factory settings and it still doesn’t work.