Issue with routine timer in 46.8

Running ST v3 with 46.8 as version.
I updated my Zooz switches to use the “new” Zooz edge drivers @philh30
I created a routine to register when a door was open (samsung door sensor) and turn a light on in the room. I selected a custom time on the routine to turn the light off. I tried several custome times and none seem to turn off the light. I selected the predefined times of 1 and 10 minutes. Both of these turn the light off at the appropriate time.
Any one else experiencing this? Any ideas of what may be going on? Thanks!

Hi, @General_KAOS

I’ve been trying to replicate the issue with cloud-connected integrations and Edge drivers, as they work correctly, I think this issue is happening only in your case.

You mentioned this was a brand-new routine, right? It happened to me that if I edited an old one and changed its configuration, it didn’t trigger correctly.

To check why is this happening, please, help us with the following:

  1. Create a routine that will stay there for the team’s analysis.
  2. Execute the event that should trigger the routine, in this case, open the door.
    Take note of the time of this attempt and share it with us, eg. 17:00 CST. This helps to check the logs and see what prevented the execution.
  3. Enable support access to your account:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Share the routine’s name
  2. If your SmartThings email is different than the one you use here in the Community, share it with me over a DM
1 Like

Routine name: Turn on garage light - open door
This is actual routine. It is set to 10 minutes, preset condition.
Just opened door at 1111 CT.
This was a new routine. I just changed to the Zooz specific driver and created new routine. Previous routine with original driver worked fine for 5 minutes.
Email should be the same as account.
I think that covers all items. If not, let me know what i skipped.

Since it looked like the 10 minute reset worked, i changed time to 5 minutes. I opened the door at 1150 CT.

Update 1: I created another routine that worked with custom time. I am guessing the routine that isn’t working might be related to the Zooz controller.

Wonder if we should loop in the developer for that driver?

Update 2: not sure what changed, other than leaving this routine as it was and adding a number of other routines using other lights. It seems to be working normally now.