New Samsung SmartThings Motion Sensor problems


(Stephan H.) #1

Previously setup using SmartLights App with GoControl PIR Motion Senor (Zwave) and GE Dimmer Switch (Zwave):
Motion Event - Turn on my kitchen lights.
No Motion Event - After 1 minute, Turn off lights.
This essentially turns off lights if there is no activity for 3+1 minutes.

I replaced the PIR sensor with the new “Samsung SmartThings Motion Sensor” (Zigbee). It was a LOT more responsive turning the lights on. However, it had a 15-30 delay before sending the “no motion” event. I thought , no problem, set the timer to turn off lights 3 minutes after “no motion” event. For some reason it does not work as expected. The lights turn off while my wife is in the kitchen and worse yet, it does not turn on even if you run around the kitchen like a maniac.

What am I doing wrong here? I don’t want to return this sensor because its a lot smaller, blends into the background better and is much more responsive.


(Ron S) #2

There is one answer! @bravenel is the solution with a brilliant SmartApp. On my phone right now and too lazy to dig the post! But hope he will chime in!


(Stephan H.) #3

@bravenel to the rescue again. He saved me with an addition to the Button Controller+ app. Hopefully he can come through again.


(Bruce) #4

Did you uninstall the prior Lighting Automation? If not, do so, and start over with that automation using the new sensor.

What you’re describing sounds like dropped events, or messed up timers. The other thing you can do is look in the IDE at My Locations, List SmartApps, and then drill into this automation. You can watch what happens as events take place by hitting refresh. You should see the scheduled job for motion inactive, and when it’s scheduled.

This could also be the ST backend goofing up. I’ve seen that today.


(Stephen) #5

Mine does the same. We will be walking around in the kitchen and the lights shut off. The motion sensor is in an area that it should easily be picking us up.


(Bruce) #6

If at all possible you should document these failures from the device logs, and send them to Support.

FWIW (which should approx. 0), my motion sensors and associated automations seem to be functioning properly.

Edited to add: Without the logs you can’t tell if it’s the device or the backend. I’m using one of the new sensors without this problem. You gotta look at the logs to see if the device is sending motion-active and motion-inactive events as you would expect. If the failure is in the backend, the lights turn off before the time beyond the last motion event, which had to be motion-inactive.


(Stephan H.) #7

Going to try this tonight. I had to revert to the old sensor so my wife didn’t throw the new sensor in the frying pan.


(Stephan H.) #8

OK…so I recreated the automation and it appears to be working better. I will have my wife test tomorrow.
I also drilled down to the automation like you suggested but the “scheduled jobs” always said “None” with a long string below it. Never changed at any point during my testing. I did click on List Events and was able to see the Turn On/Turn Off events as they happened but no scheduled jobs.


(Bruce) #9

It would show up after motion has gone inactive. The scheduled job being to turn things off. It could be that Smart Lights doesn’t act like normal SmartApps though, I don’t know.


(Stephan H.) #10

It looks like it might be different but I still learnt a new place to look when troubleshooting so it was still a valuable reply. Thanks for your help as always.


(Stephan H.) #11

I forgot to post an update. Deleting and recreating the smartapp like @bravenel suggested, fixed my issue.