Is 3460-L2 a New Version of Lowe's Iris Button?

I have bought and tried to use the Lowe’s Iris Smart Buttons, like these (which I understand were the second generation; the one that very rarely CAN work with SmartThings…i.e. for me, even though I’ve bought them from many different locations, only 1 out of every 5 that I tried would even connect, or stay connected. Then, due to an extremely POOR physical design, for the ones that doo eventually connect and stay connected, they eventually fail, because of how the process of replacing the battery ‘ruins’ the mess that had to be constructed to get it to work in the first place)…

I also know that there was an earlier version that can NOT work with SmartThings, here…

Now though, there is one that I don’t recall seeing before. Basically, it looks just like the one I know as the ‘2nd Gen’ one, but with a slight difference in visual appearance, here…

Anyway, here is my QUESTION
Is this last one actually a new, or different model/version, or just the same one with a goof in their online sales department or something?


It looks like they may be coming out with a new line of devices with minor changes. Here is possibly a new remote:

Old vs new


I also see the L2 model for motion sensor as well.


and the wall plug. I tweeted them. Let you know if they replay :slight_smile:


New model.

Although the product description doesn’t have the “works with SmartThings” box checked, the manual says

The Lowe’s IRIS Smart Button is fully ZigBee HA 1.2 certi ed and will work with other open Zig- Bee HA 1.2-certified systems.

Which should mean it can work, but it may need custom code for awhile.

One thing to be aware as with any battery operated zwave or zigbee Button device is that they go to sleep when they aren’t used for a while. This means if you don’t use them often they may need an extra tap to wake them up the next time. That leads to a lot of the frustration and also explains why some people say they work great – – but those are usually people who are using them multiple times a day. So there can be a really wide variation in user experience with these just depending how you use them.


Interestingly the new plug Model # 3210-L2 does have the WWST box checked :man_shrugging:

1 Like

It may depend on whether it will work out of the box or whether it will require custom code. Generally switches and pocket sockets will work with the generic on/off switch DTH so you don’t get the device returns from people who don’t have any idea about custom code options.



Interesting, hadn’t seen this newer version when I was at Lowes the other day. FYI, these single button Iris buttons are a PITA and really not worth it, IMHO. I bought several of them (the 2nd gen w/out the 9 dots/holes) and then retired them after family and I got sick and tired of them not being reliable. YMMV, but many have had problems w/these and abandoned them. Who knows if the newer one (w/9 dots or holes in the bottom left) will be any better, but I wouldn’t hold my breath. :slight_smile:

1 Like

This actually would be the 3rd generation of the V2 button, 4th if you count the pre-release beta devices.

  1. Beta: No eject tray, tight battery contacts. Hard to remove tray.
  2. 1st: Added eject button, battery contacts still tight. Tray usually doesn’t eject properly.
  3. 2nd: Fixed battery contact tightness, altered eject mechanism to push the tray out further.
  4. 3rd: Cosmetic changes so far.

This is a SmartThings DTH issue. The latest firmware helps but the buttons still exhibit the same behavior albeit less often. When you pair one of these to an Iris hub they fire off every time they’re pressed. The LED also does not flash red 3 times at 1 second intervals on Iris.

I can only speculate; either there’s a configuration cluster that needs to be set, or the button is waiting for an acknowledgement from the hub. Absent a Zigbee sniffer we will probably never know. I believe it to be the latter. When connected to Iris I’ve noticed that the LED doesn’t even blink. With the older V1 button, the LED ring would light up when the command was executed, sometimes a few seconds after you pressed the button. It would be great is Lowe’s developers could share the secret sauce, but I doubt we’ll see that happen.


Thanks, JD.
Very helpful, as usual. I don’t know why you’re in your physical ‘condition’, and I’m the one that’s too lazy to just freakin read something to find this out - lol - but I guess your bank account of IOUs from this Community continues to grow. :slight_smile:

OK, I get that, but that’s not even what I’m referring to in relation to how badly these things (the 2nd Gen ones I have) are.

I take one out of the box, attempt to pair it, and 10 times out of 10, they NEVER pair on the first try. In fact, it’s usually only on attempt 5 or 6 that the ones that pair even pair.

Then…4 out of 5 never pair at all.

Then…once I found out about what’s wrong with them, and why they don’t pair (i.e. the contacts issues, etc), and after I manufacture my own ‘fixes’ to go on the inside of the case of these things in order to force the contacts to…um…make contact…the d@mn things are so hard to close that it’s stupid.

Then…IF it even works at all after said ‘fixes’, once the battery eventually dies, opening the case to replace the battery usually results in ruining the ‘fixes’, and
often reveals that application of the needed ‘fixes’ has caused the contacts to break something else, and the whole thing becomes unusable altogether (i.e. No, I’m not going to get out the soldering iron and spend another number of hours dinking around with it to MAYBE get it to work again (for a while).

Nah…it has nothing to do with it ‘going to sleep’. In my experience (and maybe it’s because every Lowe’s I’ve gone to sold me a bunch of ‘beta’ items or something), these things were NOT ready for prime-time, and should NEVER have been sent out the door to paying customers.

^^^^ THIS ^^^^

Wow…I am so oblivious. I never knew any of this. lol
Thanks for opening my eyes. :slight_smile:

I assume then, even though I bought them relatively recently, the ones that I have must all be ‘beta’ units.

They have no ‘eject’ mechanism of any kind that I can tell; only a slightly-loosening mechanism lol

The only way I can ever open them is to get out my very rigid dental tool (i.e. the kind with stiff wire would never be able to help open this sealed crypt), press in the tiny thing that looks like it’s supposed to suggest the concept of a release lever, push in my dental tool, turn it, and force it open.

So, have the tray opening issues AND the battery contacts issues been resolved with #3 on your list?

p.s. If anyone here has an inside connection with Lowe’s, please let me know. If they offer to replace these bogus, unfit-for-market units with ones that have been redesigned and have all of the known problems discussed above fixed, I would be happy to give them a try. There’s just no way I can justify paying for them though…unless and until I have been able to test free ones, and verify that they do indeed work. Also, if they work, I will absolutely buy more of them.

1 Like

They got the new motion sensors in at my local Lowe’s. Curiously they are $5 cheaper than the old ones. New packaging with a new Iris logo.

1 Like

So any idea if it works? I was at my local lowes this morn they have a
bunch that they just put out.

1 Like

Not sure. Have two of the last gen sitting in a drawer waiting to use, so didn’t buy it. It physically looks the same, so I’m guessing it will still work. If they’ve changed the fingerprint you will ha e to manually assign the smartsense motion handler in the ide.