Iris keypad network light blinking - drains batt

I have the Iris keypad (new) configured with my Smartthings hub using the DTH from RboyApps. I have a few pistons setup along with the Lock User Management app, and the system is working as expected. However, the network light in the upper right hand corner continuously blinks draining the battery. It seems I should be able to stop that behavior after pairing by pressing the tamper sensor switch once, but that isn’t working.

Per various directions, I’ve tried removing both batteries, inserting a single battery while holding tamper switch, waiting until it pairs and then inserting the second battery (which reading indicates will stop the blinking light). This didn’t work. I’ve also inserted both batteries while holding the tamper switch, waiting for it to pair, and then returning it to the wall which will activate the tamper switch. The light still blinks. Ack.

How far is the device from your hub? Are you pairing it in the final location? Does it pair successfully?

20 feet. Pairing at final location. It pairs successfully. Just continues to blink

I had a similar problem with SHM delay. Tonight, I had to replace the batteries to my keypad and when I did the keypad would not immediately reconnect (expected). So to fix this, I had to re-pair it with the smart things hub. I had to take both batteries, replaced one battery while pressing the tamper button on the back for two seconds, and then replacing the second battery. The wireless light started blinking. I then re-paired it by adding the device to SmartThings app (using add device) (having removed the device from SmartThings already already), and then before adding to SHM delay, I pressed the 4 digit code and then on button. The light blinking problem stopped. I then added it to SHM delay and it’s working fine and the light is not blinking.

2 Likes

My wireless LED in the upper right was blinking a short, then a long flash in a repeating pattern after replacing the batteries and re-pairing the keypad. Otherwise the keypad was working fine. Of course, the batteries would certainly have a shorter lifespan.

I’m on Hubitat now where I can see the battery level and it was showing 75% even though the batteries were new. They measure 2.9 volts while in the battery holder. I repeated the process several times with the same result.

I took the batteries out so as not to drain them. By sheer luck, I put them both back in after waiting about 30 minutes without doing the re-pairing process. The wireless LED stopped flashing and the keypad was paired! Battery status is now showing 100%.

Just a guess, but maybe the battery voltage level detected has an impact. I don’t recall if the SmartThings hub shows battery level but if not, it may report it occasionally in live logging.