Iris/Centralite Keypad dropping from network


(Arn B) #1

Having issue with both Iris and Centralite/Xfinity keypads since the update to Groovy language.

When entering a pin the keypad’s network light shuts for about a 1/4 second, then turns back on. However, it appears the device has “timed out” and does not react to the command setting the device’s arming status light, causing all the Centralite’s status lights to start blinking and the Iris does not show the current system status. The status request is properly processed by ST SHM. Never had this issue before.

Originally reported by me on Hub Beta testing forum where it occurred almost 100% of the time on latest beta hub firmware. However it continues about 25% of the time after reverting to hub firmware 22.14.

Is anyone else experiencing this issue?


(JIm) #2

Mine Seems to be OK.


(www.rboyapps.com - Make your home your butler!) #3

Have you tried rebooting the hub?


(Arn B) #4

Yes while on the beta release when the hub refused to connect to any devices. The hub was subsequently reverted to 22.14 which required a reboot. However, I will do it again. Who knows…

Rebooted hub now via the IDE

Just did about 40 arm disarms. Had 1 failure.


(www.rboyapps.com - Make your home your butler!) #5

ST’s first troubleshooting step - Reboot :wink:


(Arn B) #6

True enough, but there have been times it was almost a drop kick.


(JIm) #7

I’m having a similiar issue. I had a keypad that I wasn’t using. I wanted to give it to a friend. I removed it from my system. Did the factory reset, batteries out for 10 secs, held tamper switch and inserted battery. It did not go into pairing mode. Tried this a number of times with no luck. Any ideas on how to get it to pairing mode?


(www.rboyapps.com - Make your home your butler!) #8

Try rebooting your hub first.


(JIm) #9

Finally found the secret for putting the IRIS keypad into pairing mode.

While pressing the tamper switch insert at least 1 battery. As soon as the keypad lights up, release the tamper switch. Put ST app into add a device. Then press the tamper switch 5 times.


(Arn B) #10

Similar to the Iris’ Keypad Documentation. These devices can be a true PITA at times.

troubleshooting
Step 1
Remove and replace batteries.

Step 2
Remove the keypad from the
wall and press the wall tamper
switch 5 times.

Step 3
Remove batteries from keypad.
Press and hold the wall tamper
switch while reinstalling a bat-
tery. Once the keypad illumi-
nates, release the wall tamper
switch. Refer to “Getting Started”
to rejoin the keypad.


(JIm) #11

The problem I was having the online instructions on IRIS didn’t mention the 5 times push of the button. I finally found that info on a Centralite keypad, which is the same.


(Arn B) #12

The good news is you got it working. Even with the correct instructions these devices can be difficult to pair.


(Arn B) #13

Regarding my original post on this thread about the keypads timing out, then dropping off the network when a pin is entered.

This appears to be a random bug due to slow processing on the cloud and possibly a delay with the internet response. I’m not sure why no one else is encountering this issue.

With the help and suggestion of tech support (Thanks @Zach_Varberg and @tpmanley ) I was able to eliminate the issue by issuing the the pin acknowledgement in the DTH immediately after the pin is entered, rather than in application code, in my case SHM Delay, after a bunch of processing. This also required disabling DTH routines acknowledgeArmRequest and sendInvalidKeycodeResponse by placing a return false statement at the start of these routines.

For now my smartapp SHM Delay is compatatble with my personal version of the keypad DTH and the version suggested in the SHM Delay documentation. A performance improvement change to module SHM Delay made in an attempt to fix this issue, will be published in the next few days.