iOS 2.2.0 - Release Notes

@Aaron - You are partially correct. I can setup the widgets again, but each time I get forced logged out they go away and need setup again.

@Aaron

My widgets have been reset and remain set up, but when I access them, the widgets come back with red feedback, telling me that they did not execute. Some times they work just fine (usually if I’ve been in the app recently), most times they come back red.

1 Like

Regardless of your theory, widgets do not work, plain and simple. Why is it that with every software update something always gets broken, seriously?

I am getting the log out issue as well. Seems pretty random. But what I do know is it is driving crazy.

Interestingly, I have gotten this message about every second time since I first got SmartThings in April. So nothing to do with the new App at all for me.

But other than that, the new App has worked just fine for me. Better than the old one in fact.

Hello All, There are 2 known big issues with the 2.2.0 version of the app, not to say there are others but we are planning a follow up release this month. The two issues do have fixes and are in QA right now.

  1. Issue with users getting logged out when crossing their geofence and NOT having a network connection yet.
  2. Widget and Watch not working.
5 Likes

Thanks for the update!

@slagle - With such big issues, why not remove version 2.2.0 from the app store and roll users back to version 2.1.5 which did not have these paralyzing bugs?

1 Like

Looks like you are relatively new to the forum. You have learned quickly and are correct. Expect it every time they release a new version. :frowning:[quote="[deleted], post:86, topic:57559"]
Thanks for the update and hopefully a quick resolution… I’ll roll back to an older version of the Smartthings app for now; it’s a bit complicated to do
[/quote]

How do you get the old version to roll back to? When I was on Android it was easy I have had an app installed that backed up every app I wanted to and could just roll back directly in the phone. I have not figure out how to do this in iOS yet. I have read that you can backup with itunes but I haven’t tried it yet. I don’t see a backup option so confused by how this is done.

Before you install the new version, you have to have backed up using iTunes on a laptop. That back up will stay there, unlike the iCloud back ups that keep getting overwritten.

Thanks, that’s the part I don’t seem to know how to do. I plug in my phone and start itunes. It says backing up. But I can’t figure out how to confirm that my apps are backed up. When I open “my apps” there is one app in there and it’s not even one I have installed on my phone.

Google search says to select File->Device->Transfer purchases but I still can’t see if it worked anywhere.

The one part that isn’t always clear, is that you have to have installed iTunes on the laptop and you have to use iTunes on the laptop, not on the phone.

So expect 11 more days of this problem, is what he’s saying. Yes, my family is loving 11 more days of alarms going off because the app can’t stay logged in and use geofence.

Luckily I programmed my door locks to now disarm the home when we arrive if we enter the right codes. Woo ST! Always a way around the failures /sarcasm

1 Like

OK thanks but I guess I am not being clear. Maybe I should start a new thread this is off topic. I see did the backup, I see the backup. I don’t see a way to know what is in the backup. It just says backup and the date, when I try to restore it says I need to turn off the phone to restore. Makes me think it will wipe everything and restore but I just want to restore one app.

Man I really am missing android. But only for Smart Things app restore. Every other app is 100% stable so far and I really like the speed of iOS. I really can’t wait to get rid if ST!

Thanks, I check it out. I really don’t understand why they make this so difficult. The ability to test a new version and revert back if there is an issue seems like a pretty basic feature to me.

EDIT: Checked out the link but it is for a tool on Windows but I have a Mac. OH well looks like I am stuck with no ability to revert apps.

I just tested and this is happening to me also. What I noticed was after opening the app and then trying the widget, it works. This most likely has to do so with some sort of login session timeout since they changed the security surrounding authentication. Tagging @slagle and @jody.albritton for escalation.

Thanks for responding. I should have mentioned that I launched the app and they worked after opening the app. However, they stopped working again when I tried a couple of hours later.

The widgets I had setup before 2.2.0 had to be selected again after the update. Since then, they do not work consistently. Instead of turning green when activating the widget they turn red. Thanks for any help.

To find your files on your laptop, you’ll need to find where iTunes stores all it’s files. On a Mac, you need to go to your Users (typically your name) folder > Music > iTunes > ITunes Media > Mobile Applications

On a PC, it should be similar but I’m not sure.

Inside that folder is where all the “.ipa” files are stored including older versions that you may have downloaded. If you’ve only downloaded apps directly to your iPhone but not sync with ITunes, then you won’t have any of the older versions. To keep older versions around, it’s always good to sync your apps with ITunes or download directly into iTunes first, then sync with your iPhone.

I haven’t done this in a while, so I might be wrong, but to roll back to the older version, remove the latest version of the app and then resync the old version back to your iPhone.

On the Mac, when you update an app in ITunes becuase hey there was an update, the old version is sent to your trash folder. It’s there until you empty your trash.

1 Like