SmartThings Community

iOS 2.14.0 released (1/30/18)

(Jeffrey Ropp) #86

Happy to report that my issue has disappeared as well. Thought it was because I had tinkered with odd characters in the device handler for the iComfort thermostat. Perhaps it’s the new fix. Either way, thanks.


Rendering of tiles is now completely messed up. Both custom and stock device handlers

(Rick) #88

All is broken. Custom dth and normal. Looks like im downgrading to 2.13 all works fine in there!

(Kevin) #89

Totally stock ST motion sensor and DTH. Wasn’t like this last night. Woke up and was looking at things when I noticed almost all my things now have rendering issues.

iOS BackGround Colors & Labels broken
(Barry) #90

Additional context and background here:


How do you get that overview of doors, lights and motion sensors on your dashboard? I can only get SHM, smartlocks and favorites

(Jimmy) #92

You have to be an OG from before the V2 hub came out and then never have deleted those apps. They aren’t available to install anymore.

(GFam) #93

Still on going issues that I am seeing:

  1. State labels that were not specified are showing state ${name} or all devices.
  2. Background colors for all multi-tiles are messed up - i have generic and thermostat tiles
  3. Humidity icons is showing smartthings icon and refresh icon is completely missing from tiles where they are set.
  4. HTML tiles are not rendering at all and display the message “An unexpected error has ocurred”
  5. All DTH and custom device handlers under favorites on main dashboard are greyed out and disabled.

After the recent outage issues releasing such a buggy app is really acceptable.
Smartthings should revert iOS app to previous version and fix and TEST all issues before releasing an update.

the working version are android and non-working iOS

(GFam) #94

How did you get this downgrade menu on iOs? can’t figure it out

(CJ) #95

I’ve spent a few hours this morning trying to figure out what I did to break my thermostat device handler. So glad I found this thread!

My interface looks like this, and sometimes the temperature buttons work, and sometimes they don’t.

Unlike @Rickybobby, I don’t have a jailbroken phone, and I use iCloud backup instead of PC/Mac, so I can’t downgrade. Please ST, get this fixed!

(CJ) #96

@Rickybobby has a utility installed called AppAdmin, but it requires you to jailbreak your phone.

If you have your phone regularly backed up to a PC or Mac using iTunes, you can find instructions online to restore an old version of the app from a backup of your phone using iTunes.

If you haven’t jailbroken your phone, and you don’t have a PC/Mac backup in iTunes, which I think is most of us now that we rely on iCloud backup, then you are screwed until ST updates the app again.

(GFam) #97

Ahh - thanks for that. Not going to jailbreak just for ST mistake. I guess ST ought to downgrade for everyone on iOS

(Rick) #98

Yeah sorry didn’t mention that, really it should be a option for all iPhones since I don’t know how many times I have used it. When a dev pushes a bad update or removes features. I believe there is a way to do it in iTunes with a admin corporate version of iTunes.

I believe that might be a option. At least with versions in the future I would suggest using a tool to backup apps off your iOS device. I know people do that without jb devices. Then these users store the versions of apps & archive safely on there computer. :slight_smile:

(Rick) #99

Yea as the other user stated need to have had st for a long time. I think they need to allow us to customize the dashboard and create this again!

ST Also more refined are you listening here!!?

I accidentally deleted all presence sensors and lost the family section. So I use to have more sections.

Also allow us to run our own offline container version of the ST cloud. This would allow for offline usage when there is no internet. They know they can do it. If there worried about potential security issues then encrypt the whole container. Many ways they could approach this. It would set them apart as no cloud based automation system is doing this.

Do you want incentive in doing this ? Think of lowering that $$$ AWS bill your footing for all of us using amazon servers for the cloud part and then letting us set the primary target to local and backup to cloud. As I know many of us would simply implement it.

There is a reason why apple watches and implements allot of the things that jb community comes out with. Same can be done by listening to us. Next would be a app type store with a max $ limit. Again I don’t know of anyone else doing this.

(Steve) #100

We worked all weekend to fix the recent tile-related bugs. You can read about it here: Recent Tile Bugs (2.14.0)

(Andreas A.) #101

Steve, thank you for a very through follow-up and getting the issues resolved! :clap:

(Mr.T) #102

So today my Smartthings app on my iphone has been telling me the presents has been ping-ponging for the last hour (even though the phone is sitting on the table)

Also, when I try to get into the Smart Home Monitor section of the app, (where it shows “everything is OK”) it sits on the first tab “Status” with no content. Same for the other tabs if tap them. If I pull down for a refresh, I get:

“The operation couldn’t be completed. (NSURE ErrorDomain error -999”.)

It took 10 minutes for the screen to unfreeze and give results!

What the heck!!!

( - Make your home your butler!) #103

@Brad_ST there’s a new bug in the iOS and Android app. When Device Handlers have an input preference set with the flag required: true it ignores it and saves the page even if the user hasn’t entered any value.

Easily replicate, add this input to any device handlers preferences:

input "testState", "enum", title: "Select a state", defaultValue: "last state", displayDuringSetup: false, options: ["0": "last state", "2": "on", "1": "off"], required: true

Notice this isn’t an optional but a required value, however it’ll save the page even if the input is empty

It used to work fine with the older versions. This is a regression bug, it was reported many releases ago, was fixed and now it’s back.

(Keith G) #104

I’ve been working on improving the functionality of some DHs user with Xiaomi sensors, and noticed displayDuringSetup is ignored, even though the Developers Docs claims it should work with DHs. I’ve also tried using required: true together with displayDuringSetup: false and that didn’t work either.

Is displayDuringSetup not working in Device Handlers also a new bug?

( - Make your home your butler!) #105

displayDuringSetup has never worked as far I can remember.