Integration of Innr Smart Lighting products

Hello all, I’m trying to connect my Innr smart bulbs to the ST hub, but no success. On Zigbee level they seem to connect, but they won’t show up in the App. Tried to create a Device Handler for them (I have the Zigbee details required for this) but then get back the following message: Run Locally Permission not allowed for DeviceType: 7a85c6a2-c1ad-4aff-87a2-f3612b3e4593

Who know what this is, and why I get this error message ?

Alternatively, does anyone already have DH for Innr bulbs ?

Did you get to the bottom of this?

Are you using an ST published DTH as an example to crate a new device type?

Hi Paul,

I used a ST published DH and then adapted it for Innr Bulbs, but that didn’t work. Meanwhile I understood that ST is working on adding Innr bulbs to their generic DH’s for white, tunable white and color bulbs, so this should already work or work very soon :blush:.

After lots of research - This worked for me.

  1. Factory reset the bulb by turning off and on six times. On the final time the bulb will flash to confirm the rest.
  2. Turn the bulb Off
  3. On the mobile app go to ‘My Home’ and select the ‘Things’ tab.
  4. Press the ‘Add a thing’ button.
  5. Now turn on the Innr bulb at the switch.
  6. The bulb will flash twice as it goes into pairing mode.
  7. The app will display a new “thing”. Accept and rename as necessary and save.
  8. Now go to the Samsung IDE on your PC ( and go to the ‘My Devices’ Tab.
  9. You should see your new “Thing” or whatever you renamed it as.
  10. Select this and press the edit button.
  11. Change the device type to ‘Zigbee smart bulb’ – Pick the one that best describes your bulb.
  12. Save it.
  13. Go back to your Mobile app and Hey Presto! - A working controllable bulb.

Hope it works for you


Hi Nick. Thank you for your helpful post. This worked perfectly for my Innr B22 RGBW. I thought I was going to have to send it back but I’m now ‘enjoying’ bridgeless Smart Bulb functionality. Paul

1 Like

Top man- this works a treat.

1 Like

They added the fingerprints for some of their bulbs to the default handlers back around march

Has anyone managed to add the INNR lightstrip in SmartThings? ( Innr Flex Light RGBW FL 130C). Works great with hue hub, but can’t seem to see it in ST.

tried adding device handler found HERE

which it says adds the FL 130C but cant save the handler as it errors with Run Locally Permission not allowed for DeviceType: bcca9699-02b5-4f20-ae35-02c072f1bcaa

any help appreciated ! thanks
Bill P

That’s the default handler SmartThings uses. If the hub isn’t even finding the device, it’s not a handler problem. It should show up as a “thing” at the minimum.

Very strange…the INNR strip is connected to the Hue Hub and works perfectly , and all other bulbs on that hub did not NEED to be added to smartthings…they just appeared…in addition Samsung says that particular INNR strip IS supported
No idea how to progress it now …anyone got any ideas?


Bill P

weird solution… I used the hue b smart app I had already and the new bulb showed up as not added there…so I added it under “choose bulbs”
it then immediately showed up in ST as expected… very odd, but all working now

Bill P

1 Like