Having an issue re-connecting a zigbee bulb

zigbee

(Adrian L Thomas) #1

I managed to add an Innr Bulb (Zigbee) to my ST hub. However after having a few issues with the IDE (kept getting odd Java errors), I decided I’d reset the whole thing. I removed the device from the hub and put the bulb back in pair mode. However I don’t see the bulb when I go to add a thing now - and the bulb also appears to be connecting back to the hub (I don’t see this on the hub itself, but the bulb flickers which indicates it has connected).

Naturally I’ve tried turning the hub off and on…

Any ideas on how I can add the bulb as a thing again?


(Robin) #2

I had an Osram Lightify RGB unit (Zigbee) do something similar few months ago.

When I first connected it, it came up just fine but I stopped using it for a while and removed it from ST.

Months later I tried to connect it back into the system (wanted to use it to light up a pumpkin during Halloween) and no matter what I tried it never appeared on the ‘add things’ page. I eventually gave up and threw it in the bin!!

A week later I noticed it was listed on my things page despite not showing up during inclusion… To make it worse the bins had been collected!!

Silly question but have you double checked your list of devices under ‘things’ just to be sure?


(Adrian L Thomas) #3

Thanks for the response Robin. It’s definitely not listed on the things page!


(Neal (www.zebrablinds.com / www.zebrablinds.ca)) #4

Did you try resetting the bulb and then connecting to ST? I’ve had bulbs only connect after 4 or 5 tries (even though they flicker to indicate they connected).


(Adrian L Thomas) #5

Hi Neal,
Yes I’ve tried resetting the bulb a handful of times to no avail. The procedure for Innr bulbs is switching it off and on, 6 times. I see the double flash to indicate that it is in pairing mode, and then a few seconds later I get a single flash that show’s it has connected. It’s definitely something to do with the ST hub because if I turn the ST hub off, and then put the bulb in pairing mode, I don’t get the second flash that indicates a connection.


(Neal (www.zebrablinds.com / www.zebrablinds.ca)) #6

Can you check if you have any generic devices in your ide. I used to have a completely generic device pop up in my IDE and I would have to manually assign the DH. Otherwise I am stumped and support would be the best bet.


(Adrian L Thomas) #7

Nope, nothing generic in there. Just the SmartThings devices I would expect!


(Robin) #8

Have you tried hitting it with a hammer :smiling_imp:


(Robin) #9

On a serious note, maybe try a different sequence like putting the bulb in inclusion mode before asking the ST hub to scan for new devices or visa versa.


(Adrian L Thomas) #10

Getting the hammer, brb :wink:

I’m not 100% sure what you mean. I’ve tried putting the bulb in pairing mode and then opening the app to add a new device - if that’s what you mean? However it appears to connect to the hub fairly quickly thus I never see it on the app anyway!


(Robin) #11

Hammer it is then!!


(Robin) #12

That’s what I meant… Also try the reverse (start ‘add device’ scan before putting the bulb in pairing mode).


(Adrian L Thomas) #13

You will never guess what. Clearly the hub got scared at the fact I was going for the hammer as it has just appeared back in the Things list! That’s really annoying. Perhaps something gets cached overnight? Or not fully removed until x period of time?


(Robin) #14

Maybe same thing that happened m to me then… I noticed it in the ‘things’ list a few week later and was surprised I hadn’t noticed it at the time… I’m thinking now that it took a while to appear hence why I originally missed it and trashed the d a m n unit (skipped the hammer part)


(Robin) #15

Then you must mark my devil post as the solution!! :smiling_imp:


(Adrian L Thomas) #16

Ha, well at least it’s connected again. Will start a new thread for the weird Java exceptions I was getting.

Thanks for your help!


#17

Hi just bought innr bulb to try
To connect it was it on auto (add a thing) ?

Many thanks
Martin


(Adrian L Thomas) #18

I just turned it on and it appears when you search for items. It didn’t show up immediately for me though, I had to turn it on, put it in pair mode and give it some time to find it.


(Scott H) #19

I’ve tried desperately to get these working with smartthings a while back but they weren’t having any of it. Same thing, it flashed twice to show it in pairing mode, then flashed once to indicate a connection with the hub, but smartthings just seemed to be unable to find it.

Can I just confirm: did you put your smartthings in pairing mode, then put your innr bulb in pairing mode? How long after the bulb flash (to indicate a connection to the hub) did you leave smartthings on the search screen before it found it?


(Adrian L Thomas) #20

I put the Innr bulb in pairing mode (didn’t need to do anything with the hub). Honestly not sure on timing, it was more that I got frustrated, left it for the night and checked it the next day and it showed up!