Having an issue re-connecting a zigbee bulb

I managed to add an Innr Bulb (Zigbee) to my ST hub. However after having a few issues with the IDE (kept getting odd Java errors), I decided I’d reset the whole thing. I removed the device from the hub and put the bulb back in pair mode. However I don’t see the bulb when I go to add a thing now - and the bulb also appears to be connecting back to the hub (I don’t see this on the hub itself, but the bulb flickers which indicates it has connected).

Naturally I’ve tried turning the hub off and on…

Any ideas on how I can add the bulb as a thing again?

Thanks for the response Robin. It’s definitely not listed on the things page!

Did you try resetting the bulb and then connecting to ST? I’ve had bulbs only connect after 4 or 5 tries (even though they flicker to indicate they connected).

Hi Neal,
Yes I’ve tried resetting the bulb a handful of times to no avail. The procedure for Innr bulbs is switching it off and on, 6 times. I see the double flash to indicate that it is in pairing mode, and then a few seconds later I get a single flash that show’s it has connected. It’s definitely something to do with the ST hub because if I turn the ST hub off, and then put the bulb in pairing mode, I don’t get the second flash that indicates a connection.

Can you check if you have any generic devices in your ide. I used to have a completely generic device pop up in my IDE and I would have to manually assign the DH. Otherwise I am stumped and support would be the best bet.

Nope, nothing generic in there. Just the SmartThings devices I would expect!

Getting the hammer, brb :wink:

I’m not 100% sure what you mean. I’ve tried putting the bulb in pairing mode and then opening the app to add a new device - if that’s what you mean? However it appears to connect to the hub fairly quickly thus I never see it on the app anyway!

You will never guess what. Clearly the hub got scared at the fact I was going for the hammer as it has just appeared back in the Things list! That’s really annoying. Perhaps something gets cached overnight? Or not fully removed until x period of time?

Ha, well at least it’s connected again. Will start a new thread for the weird Java exceptions I was getting.

Thanks for your help!

1 Like

Hi just bought innr bulb to try
To connect it was it on auto (add a thing) ?

Many thanks

I just turned it on and it appears when you search for items. It didn’t show up immediately for me though, I had to turn it on, put it in pair mode and give it some time to find it.

I’ve tried desperately to get these working with smartthings a while back but they weren’t having any of it. Same thing, it flashed twice to show it in pairing mode, then flashed once to indicate a connection with the hub, but smartthings just seemed to be unable to find it.

Can I just confirm: did you put your smartthings in pairing mode, then put your innr bulb in pairing mode? How long after the bulb flash (to indicate a connection to the hub) did you leave smartthings on the search screen before it found it?

I put the Innr bulb in pairing mode (didn’t need to do anything with the hub). Honestly not sure on timing, it was more that I got frustrated, left it for the night and checked it the next day and it showed up!

I’m very interested in this thread as I have bought 4 Innr bulbs and can’t get them to connect. I mistakenly thought the ST would negate the need for a hub but it’s looking like a lighting hub will be needed like the Hue bridge. I also see the double flash and then the single flash indicating that they are paired but they do not appear as a thing. I’ve tried about 50 times using various methods. I have managed to see them in the list a few times but only as an “unknown” device that cannot be controlled. Once I also saw an error message in red saying the hub could not be found. I assume it is referring to a lighting hub as previously mentioned?

I just brought an innr I85C colour bulb + smartthings hub (this is my first smart home hub/device). After doing some basic research on hue, zigbee and z-wave obviously purchasing the smartthings hub for it’s software and it’s support of both protocols.

I purchases the innr bulb as I read a couple of review where people said they worked, it was much cheaper than a hue bulb and did not require but in theory also works with a hue bridge should I have gone that way.

But to my disapointment after serveral hours of trying to pair it I got no where and starting trawling the web again for answers only to find many people saying they won’t work with ST.

Thinking I would have to return it I tried a few more times to try and pair it and on the 8th time a generic ‘thing’ shows up on my ST hub.

I can’t do anything with it so assume it’s not properly paired, and tell the ST hub to forget it and then try pairing again, this time I get it on the 4th attempt but again it’s a generic ‘thing’

Come back to read and find these posts stating they innr are doing a custom device handler, but can find no mention of that anywhere else not least with innr support.

Then I read you can crate your own so long as you can get it paired and can get the zigbee info including device ids and clusters.

On this basis I created my own from the Zigbee RGBW template, fill in the bits for the innr device from the logs, remove my generic thing, repair and it works. All features seem to be a-ok, brightness, hue, temp and on/off.

Then had the idea that I might now need my handler, so again remove the thing, repair and get a generic thing again, edit it to use the Zigbee RGBW device and type and it’s a-ok.

So perfectly compatible if you willing to edit the device or if you want it to be found automatically create a custom device type.

The real problem lay in the pairing of it. I have now have had 40 attempts at pairing with 10 successful, with the last 6 being consistently reproducable.

The issue is timing in the pairing process. You must not wait too long or too soon after you start ST discovery.

I found the following sequence works for me

Turn bulb on and off at switch 3 times with 1.5s delay between earch switch.
Start ST discovery (within 1.5s - so tricky, have to hold phone in 1 hand, other on switch)
Continuing switching the bulb another 3 times, go the 2 flashes and then single flash indicating paired and it shows up on the ST hub.

Now the real sore point about all of this is not just the timing issue, but the fact the bulb lies about being paired, in every single attempt to pair the bulb, it does it’s usual 2 flash to show active, then single flash following to show paired, when in fact it was no paired.

There is certainly no one in the street I live with any other zigbee devices so this bulb just flat out lies about being paired.

Sorry for the long rant my first smart device has been quite an adventure, but hope its useful information.

Bulb lies about being paired.
Bulb needs explicit timing to actually pair, (9s total, 4.5s of switching 3 times with 1.5s gaps, then ST discovery, followed by another 4.5s of switching)
Thing is not recognized, but manually editing thing and assigning device type Zigbee RGBW works.

Hi Adam,
Could I ask what bulb and device handler you’re using? I’m using the Innr RB162 bulb (white, colour changing) and have tried various device handlers, including the ZigBee White Color Temperature Bulb device handler to no avail. I’ve also just tried running through the same steps you provided, with no luck.



It’s an innr RB 185 C, B22 fitting.

I have 3 bulbs total now:

1st Bulb took a long time to get the timing of the pairing but I am able to consistently pair it and control it.
After pairing it had a valid ‘Device Network Id’ and ‘Zigbee Id’.

2nd Bulb could not find the timing but have managed to pair it a couple of times out of around 40 attempts and again control it (but have not been able to find an consistently reproducible pairing scenario), again it had a valid ‘Device Network Id’ and ‘Zigbee Id’.

3rd Bulb I managed to partially pair once. When I say partially I mean it showed up as a ‘Thing’ and I assigned the same device handler I had assigned with the previous 2 bulbs. But was not able to control it. Upon later inspection it had a ‘Device Network Id’, but no ‘Zigbee Id’ showing in devices. I have not been able to pair this bulb again in around 60 attempts.

So it looks like some pairs are ‘good’ pairs and some pairs are ‘bad’ pairs in that ST is not aware of their ‘Zigbee Id’ and in this case are not controllable even with a valid handler.

The device handler I am using for all 3 bulbs is ‘Zigbee RGBW Bulb’ which comes OOB with ST. It should noted this is not automatically assigned. I assigned it by editing the device and changing the handler.

Options I have not tried yet but will when I get the time are:

  • Complete reset location / hub and see if I can get it to assign a different channel to see if this has any effects on pairing.
  • Buy a zigbee sniffer
  • TBD

On the second bulb after a reset I get the 2 flashes and then consistently following that around 1s later I get the third ‘paired’ flash but usually nothing logged in the hubs event logs, unless it really does pair and ‘Thing’ shows up in my list at which point the clusters/description are shown in the hubs event log.

On the third bulb after a reset I get the 2 flashes and then a the timing of the pair flash can be pretty random, it can come 1s after, 1 minute after or in quite a few cases never.

So it’s all a bit of a mystery still why these bulbs or the hub are so inconsistent in behaviour.

I will try and upload a video of ST controlling it and will share some of my logs screen shots as well.

Should be noted, that between all 3 bulbs I have had around 300 pairing attempts and a total of 14 completed and successful pairs :frowning:

Thanks Adam. I’ve purchased that bulb - will give it a whirl.

Hi all,

I’ve just bought one of these today. Pretty much having the same issues as above.
I can get the ID and add it manually in ST, although having no luck controlling it once I have it.

Diid either of you (@AdrianL & @obble80) get any further?
I’d hate to buy yet another hub, especially if they are working on a device handler. But I aint got the patience for that! :slight_smile: