Installing published smartapps

Am I a freaking idiot? I started writing my own app, then read here in the forum about someone else who wrote the same app and shared it. Where the @#$%# are shared apps? When you publish an app to the world how the hell does anyone find it and install it?


It’s not just you… there are quite a few threads discussing the issue, the lack of a proper gateway into the “vetted” repository of shared apps, etc.

Right now your best option is to go into the IDE and click on the “Browse SmartApps” near the top right. You can then take a look at the sample apps or browse all the share apps by category, and insert them into your own by overwriting yours (red button on the bottom right).

There are still a lot of people out there that have stuff published just for them, or embedded in posts or hosted on github, so if you’re looking for anything in particular and you don’t find it on the shared apps, searching the forums might yield some results.

I believe that SmartThings’ plan it to eventually have a “App Store” like setup where developers can push their apps for people to grab (and perhaps buy?). But this isn’t done yet.

Currently if you go into the IDE you can browse apps that others have shared. I wrote a little tutorial many months ago on how to do this:

Some of that might be slight out of date with some of the fields you need to enter when starting a smartapp but the basics are still valid.

And yeah, as @viguera said, you can also find some apps in the forum and/or github. There isn’t a great way to search right now.


So, If I understand correectly, to use someone elses app, I have to create my own with bullshit details, browse for theirs, and copy it into mine. Even though an app is “shared” that doesnt mean it can be installed?

Another question…When I publish an app “For me”, where exactly do I install it from? I dont see it in the apps available on my phone.

1 Like

Hit the plus on the bottom of the dashboard. Then scroll across the top of the screen as far as you can. The last entry on the right should be “My Apps.” You’re self published apps should be there.

1 Like

you also have to log out of the ST app and log back in for the My apps category to be there after you publish for the first time.

1 Like

Thanks a lot. That was seriously confusing.


I must be missing something but where do I find the shared smart apps? I’m looking everywhere but don’t see it when I log into the IDE.

I also echo that using Smart Apps is quite non-intuitive

a) You can’t search and find shared smart apps

b) I was looking for an offered smart app for a dimmer switch I added – after thinking about one of the options I didn’t select, I want to add it in. But I can’t even find the smart app to add it back in!! (Something like “gradual wakeup” which slowly brightens the lights in a room at a scheduled time…)

c) The process of creating your own smartapp isn’t very easy – period. Mostly I think its obscure, and information on how to do it is hard to find. A tutorial or two, and a couple of worked examples would go a long way in helping with this. And having a way to actually FIND the tutorial or worked example on the Smartthings web page would greatly reduce the frustration. You might consider that as a suggestion for the community.

d) DELETED (figured this one out…)

1 Like

Check out this video:

Starting at 1:35:00 they do a demo app.

This has to be the most convoluted system imaginable. It seems to have been thrown together without any planning.

Finding SmartApps in the Android or iOS app is difficult unless you only want to find the 5 “Top Apps” they list. There is no way to find a complete list unless you choose to be a developer yourself, which the average person won’t want to do.

You think you might want to create a SmartApp but you want to see other ones first so you know what is involved. Is it simple like IFTTT or is it complex with 100’s of lines of code? But you can’t see anyone else’s SmartApp until you create your own SmartApp that does nothing first. STUPID! How does that make any sense???

This is still an issue.

This is the least discoverable way of doing this that I imagine, while still including the functionality at all. Why isn’t the browse shared apps option available in the “from a template” view? That’s still not as obvious as a separate, non-developer path to install smart-apps without creating them, but it’s light years ahead of creating an app and then being able to view the list of existing apps. And it’s not documented, either, at least not that I could find.

Device types are no better. Sure, there’s no disconnect between the templates offered before and after creation, but that’s only because you can’t share them (at least not in a form short of publishing/blessed by ST).

It seems like both shared apps and types should be available as templates for creating derived versions in the IDE and as versioned references for users not going through the developer->create workflow. Something is wrong when the norm seems to be to cut and paste text from forum posts.


sweet baby jesus its like they’re TRYING to make this process as painful as possible.

i’m a web developer, i like to think I’m a bit crafty. i have been fighting with the iOS app for over 2 hours trying to set up a simple timer. insane.

edit: i JUST found the sliding menu under setup. not sure whether to cry or move into a cave in the woods.


I tried to add a new schedule and it always updating my first entry. Do you have an idea?

This is the logs when i try to create a new schedule.

10:32:59 PM: debug Scheduling Temp change for Tue May 19 2015 23:00 EDT
10:32:59 PM: debug Current time is Tue May 19 2015 22:33 EDT, scheduled time is Tue May 19 2015 23:00 EDT
10:32:59 PM: debug Updated called with [thermostat:[Thermostat Cuisine], heatingSetpoint:19, coolingSetpoint:24, dayOfWeek:All Week, time:2015-04-02T23:00:00.000-0400, sendPushMessage:No]
10:29:55 PM: debug Scheduling Temp change for Wed May 20 2015 06:00 EDT
10:29:55 PM: debug Current scheduling check time Tue May 19 10:00:00 UTC 2015 has passed, scheduling check for tomorrow
10:29:55 PM: debug Current time is Tue May 19 2015 22:29 EDT, scheduled time is Tue May 19 2015 06:00 EDT
10:29:55 PM: debug Updated called with [thermostat:[Thermostat Cuisine], heatingSetpoint:21, coolingSetpoint:24, dayOfWeek:All Week, time:2015-04-02T6:00:00.000-0400, sendPushMessage:No]

Since this thread has bubbled up to the top again, two recent forum additions that may help with the original question:

  1. there is now a forum section for Community-created smartapps where authors can announce new work and provide support and discussion:
  1. and a short FAQ overview of how the “publish for me” process works when you’re using code written by another community member.

Is there still no way to add someone’s smart app from the mobile app?

I do not find the Browse Shared Apps selection option. I created an app and saved it. I pasted a screen shot below, hopefully you can see it.