Inovelli plug not working with new smartthings app

I finally made the plunge to the new smartthings app, and I noticed my inovelli 2 channel outlet (it’s an older model nzw37) now only allowed control as 1 outlet. I removed the device, and tried to re-add it (I found the instructions online that said to put it into pairing mode, press the power button 5 times) but it doesn’t even recognize the device to pair it. I searched through the list of supported devices, and I don’t even see Inovelli outlets listed, only switches. Is this device no longer supported, or am I doing something wrong here?

You may need to run a Z-Wave exclusion on the device first.
Also, check out this link for details on a fix. It’ll be in the newest posts.

Thank you. I went through this when I deleted the device from SmartThings. The instructions I found were to go into the menu, all devices, edit, delete device. If there’s a different way of doing it with the new app, I can’t seem to find it (plus the device has already been deleted).

Find your hub in the new app and tap the three dots in the top right. Then select Z-Wave utilities.

When I tried this, I got a “to delete z-wave devices, follow the manufacturer’s instructions.” followed by a “no devices were deleted. Try following manufacturer’s instructions again or force delete device.”

That device needs a new DTH in order to work with the new app, but you shouldn’t need to exclude it and include it.

See the following thread:

Inovelli dual channel outlet issues