Inovelli Device works in Classic app, Alexa, but NOT in the new Smartthings app

Hello all. I was updating my device by adding in a new Device Handler, as the new app didn’t really see both virtual switches in my Inovelli NZW97 outdoor (dual) plug. It would only turn on one switch / outlet. So I created a new Device Handler and then changed the type in my device.

Now the new Smartthings app says it “Can’t connect to device. Check device and try again.” To be safe, I unplugged and re-plugged the NZW97 back in. I have removed and re-installed the Smartthings app. Same error.

I am able to use the Smartthings Classic app. It is clear the device type / handler was updated, and it works like a charm. I thought to manually test from within the Alexa app on my phone and it too worked like a charm. But the new app just looks at me and laughs. Any thoughts on what else to try here? I could try to remove the device from my app, but it looks like it wants to fully exclude it and then I assume remove from my hub as well. But if I do that, and re-add, I believe it adds it back in as the old, default device time of a generic z-wave multiswitch; of which I’d have to re-setup again.

Thanks in advance for any ideas or thoughts on this!

Contact Inovelli support. They have recently published some new DTHs to work with the new app.

Thanks for the thought. I did submit a question in their forum; I’m just waiting… I did check out their support and links, and it appears to link to the same DTHs / code I have linked above.

Tagging @Eric_Inovelli @erocm1231

Hey @sawall – just to confirm, did you delete the old device handler and then re-install this one? I know it may look similar, but there are some slight modifications that were made.

In addition, please add the child handler.

I’ll look for your post in our forums – sorry, sometimes I miss them!

1 Like

I communicated with Inovelli recently and it took 3 attempts before they got me the right device handler for my bulb. Everything works now but it was frustrating …

Thanks, @Eric_Inovelli. My post on the other forum is here.

When you ask about deleting the old device handler, which do you mean? Initially, it just had the default that Smartthings applied, meaning, it was just a generic z-wave multiswitch handler, not a custom one. I just created this new DH and then edited the Type within the existing device. Does that help?

As to the child handler, I can swap that out. I used the newer one that was posted in github. Should I swap them? But also, I’m not sure if this is the issue or not? Again, it only seems to fail within the “new” Smartthings app.

Thanks for the assist / advice!

Issue resolved. See my updates here:


1 Like