Inovelli dual channel outlet issues

They all should work, but the alternate version is the one that is used most often.

If you have the NZW97 (Outdoor) then use this one:

1 Like

I realize this thread is a bit old, but you recommended trying the Z-Wave Device Multichannel DTH because the Inovelli one isn’t working for everybody with the new app (mine devices just say checking status in the new app, but I can control them in the old, and the SmartLighting app works fine, too). Anyway, if I replace the DTH in the IDE, for which device do I replace it? I have three. The multi-channel and the two child ones. Do I replace them all or what? Thanks!

I might have figured this out. I replaced the MC device with the generic MC Z-wave device. I left the two CH devices as Switch Child Device. Is that correct? Let’s see how it goes. Thanks.

So, now the MC channel device works and shows up in the new app but the two child devices still show as checking status. Any suggestions? Thanks.

Hey @rcbjr2@erocm1231 will be creating a knowledge-base article for this with instructions shortly.

What I think you need to do though is delete the Switch Child Devices from IDE and then go back into your ST App, click on the 2-Channel plug and then go to the settings part, edit a random parameter (you can go back and change it back to whatever it was) and the app should create the children again (this time hopefully without the, “checking status” issue).

I’ll come back to this thread once it’s posted in our knowledge base with a link.

Hang in there!

Edit: link for anyone who wants step by step instructions to get your 2-Channel working properly in the new app:

I about gave up and ordered two separate external plugs but just canceled the order. After messing with it for an hour or so this morning, and deleting the device, and adding it to the app again, I at least got it to work from the smart lighting smart app although I cannot turn it on and off from the new SmartThings app. I forget which device handler I finally settled on, but I think I can control the main multi-channel with the old app for a while.

Success. Now works in new SmartThings App as expected. I removed the device, reset the plug (https://www.cd-jackson.com/zwave_device_uploads/625/Step-by-Step-Instructions.pdf) using some combination of pressing the button 3 or 5 times, and added it back to the new App. It now works and the child devices are both working independently. No special device driver loaded.

Type set to: “Inovelli 2-Channel Smart Plug MCD”

I’m going to have to try that one. I think I tried it earlier and didn’t think it worked correctly. I’m using the Inovelli “alternate” one right now. By the way, I’ve been able to remove the device and reconnect it by removing it from the IDE, starting the new device process, and connecting it. It defaults to an Inovelli device handler that doesn’t work great. Anyway, I’ll have to try the “MCD” one again. I think I could control the MC but not CH1 or CH2 directly, at least not from the new app. Sigh…

By the way, I’m using the “alternate” Inovelli DTH for the outdoor plug. However, it doesn’t really work in the new app. I can see the status of the MC, but it won’t control it. I can’t control it in SharpTools, either, but I can control it in the classic app. Weird. Per someone else’s suggestion, I might re-try the “MCD” device handler to see how that goes. I also wasn’t successful in canceling my two separate outdoor plugs from Amazon because I canceled too late, but if I get this working well enough I can always send them back (or use them if I want to be able to control the device from the new app). Thanks.

When you added the plug, did you wind up with child devices? You added the plug and then changed to the MCD DTH, right? If so, did you get add’l child devices added? I now have four, two are renamed from the original Inovelli devices added when I scanned for a new device and added all three offered, and now two that were created when I switched to the MCD DTH (see image). When you added the device back to SmartThings, did you select all three plugs offered, of just the MC one? Can you see in the new ST app the two child devices? I can only see the original two I created. I think when I tried to delete child devices previously, it deleted everything, which is why I started havinig to re-add the entire device to SmartThings. Thanks.

2020-10-02_15-53-12

I deleted both child switches from the IDE. I deleted the main switch from the APP.

I then pressed the button on the plug some magic number (3? 5?) of times to make it discoverable. Did a Scan Nearby in the new App to add it back in. It was added as a

The child devices just showed up

Yeah, when mine was added, it picked a different device handler I guess. It wasn’t the MCD one that you got. My lights aren’t working in the smart lighting SmartThings app so I’m going to have to try again.

OK, success. I deleted the old child devices from the IDE. That left me with the Outlet 1 & 2 like you have. However, I kept thinking I’d have three devices in the app, but there’s only one. Even so, when I press it, I then get three options: MC, CH1, and CH2. And they work! I was also concerned that I couldn’t use Smart Lighting because I didn’t have a separate device for CH1 and CH2, but they show up in Smart Lighting! Yay.

1 Like

I’m not sure if you noticed the edited post, but I wrote an article on a method that has worked for myself many times.

2 Likes

Eric,

I tried to follow your directions. Everything works until I go to delete the child accounts. That then deletes the parent as well.

here is what I have now and it works so I am not going to delete the old child devices.

image

1 Like

@erocm1231 I can confirm the same results. When I try to delete the old child devices it deletes the entire inovelli device (parent).

@5spot @dfurst are you clicking on the child device and then deleting them from there?

@erocm1231 Yes I was selecting into the child device. After playing around I think I found a fix. In the child device I edited the device type from “Child Switch Health” to “Child Switch”. I then saved (updated). Then I was able to delete the Child device successfully on both Child devices. It seems to be working fine now.

Same worked for me. I I changed it from “Child Switch Health” to “Child Switch” and saved my changes, I could then delete them and not delete the parent.

Tested and works!

1 Like

@dfurst @5spot I confirmed that if I first change the device handler to the MCD version and then try to delete the child devices that the MCD version creates then it does delete the parent. If I don’t change it to the MCD version and delete the child devices then the parent is not deleted.