Inovelli dual channel outlet issues

I appreciate the offer. I’ll reach out to you and see what options I have. But I bought this on March 5th 2017 so it’s been just barely over a year.

And yes the led comes on. It works just fine manually, it’s just the smartthings connection that is having issues.

Doesn’t matter - we will replace it no matter how long ago you bought it :slight_smile:

It doesn’t have to show up to do an exclusion. Click on your hub - utilities - General exclusion and push device button until you see a message that device was excluded. There will be no name.

I don’t know if anyone is following this anymore, but I could use some help.

I bought several 2 channel NZW37 smart plugs about 2 years ago. They are the non-scene enabled version. I vaguely remembered installing some device handlers to make them work, and I have had all 3 devices listed under “My Home/Things” – meaning the Smart plug master, as well as each child device.

However lately one of my smart plugs was acting up, meaning although the smart plug was ON, and both child devices were ON, the plugged in lamp wouldn’t turn on. I would have to cycle the on/off button a couple times for it to work.

I figured no big deal, I’ll just exclude the device and re-add it. The problem is, I can no longer get all 3 devices to show up under My Home/Things. Only the parent device is showing up. I’d really like all 3 back for easier control.

So this is what I’ve done.

I excluded all my smart plugs, so I could start fresh. This removed all my smart plugs from My Home/Things.

I removed all my previously installed Device Handlers related to the smart plugs – I had device handlers for Inovelli 2 Channel Smart Plug and Switch Child Device.

I installed two device handlers from the Github Inovelli page:



I then added went to smart things classic app to add new device, toggled the NZW37 on/off several times, and I see three devices appear for me to rename. I rename them, then go to the My Home/Things list, but only the Master device is listed.

I log into my IDE, find the smart plug device, click Edit, and change the Type to “Inovelli 2-Channel Smart Plug (Alternate)”

However, when I check my recent activity for that smart plug master, a red error promptly appears saying "Child device creation failed. Please make sure that the “Switch Child Device” is installed and published.

This error appears to prevent me from switching the device type to the (Alternate), because every time I check the device type in IDE, it is still the original Inovelli 2-Channel Smart Plug type, not the (Alternate).

Very frustrating. Now I don’t have any of my 6 plugs working. Can anyone help?

Is there a new DH which will allow the child devices to work in the new SmartThings app? The parent device works just fine in the new app, but the child devices show to be offline.

The device works great in the Classic app as it has ever since I purchased this plug, but I’m trying to migrate everything to the new app so I don’t have to keep bouncing back and forth.

I think what you can do is delete the device handler and then re-add it and assign it to your plug in the new app and it should work.

I’ll tag @erocm1231 to see if that’s the recommended route. I always get confused here, so I may be messing something up – I swear he’s told me the answer to this 100x lol.

  1. exclude the outlet(s)
  2. delete custom DTH (is necessary)
  3. re-add the outlets

This should get it to pair using the native updated MCD enabled DTH.


One thing to keep in mind “unfortunately” :frowning: is that the current state of the new SmartThings app doesn’t really let you do much with the individual outlets. There seems to be issues in the “Automations” feature that only lets you set automations for the main switch and one child at the same time. This kind of makes things crazy like, if you want to turn off just one outlet, you have to set the automation to turn on both outlets and then turn off the one you want. That can cause a problem because you may not want both to turn on in order to turn one off.

It is really hard to explain, but it just looks like the functionality of the child devices isn’t fully ironed out yet. Hopefully it will be soon! The classic app still works and I think you can use the SmartLighting app to control outlets independently.

Correct me if I’m wrong, but excluding and re-adding will drop your ability to control the children individually within Alexa and Google unless you still have the old skills. Is that accurate?

I think the old skill will still work with the new DTH since it still has child devices.

1 Like

I created a new DH using the one listed on the Inovelli website. The child devices still show to be offline in the new app. I can control them by pressing the on/off button, but it takes almost 30 seconds for the plug to change states.

In the Classic app, I now I have a Plug 1 and Plug 2 in addition to the Channel 1 and Channel 2 , and also instead of the child devices showing the names I gave them, they show up as Channel 1 and Channel 2.

I tried changing back to the original Device Type in the IDE, but every time I select Inovelli 2-Channel Plug in the list and update, the new DH shows up as the assigned device type.

Is there any workaround to restoring individual control of the children within Alexa if you’ve lost access to the SmartThings Classic skill?

I recently migrated everything I own over to a new Amazon account, and didn’t realize the old skill was no longer available and that the new skill broke control of the children. Currently still a SmartThings Classic app user.

Came across this thread as the new app SmartThings recently forced me into didn’t recognize my NZW37. As a result I excluded and re-added the device, but I no longer have any control over separate channels in the app. Even when clicking on the parent, there are no subcontrols at all.

It’s also frustrating to keep seeing links to here and in the official Inovelli documentation only to find that url 404s. Searches on Inovelli’s site for NZW37 have been fruitless in turning up any documentation on how to properly set up this switch with SmartThings.

I assume the line was taken down because the procedure has changed, otherwise I’d seek out an archive of it.

I actually just went through re-configuring the same unit. I actually had to exclude and force delete several times to get the 2 children and parent to totally exclude from my setup. One unit about 6 times. One about 15. It just didn’t want to let go. I tried in the old and new app, back and forth. Once I did that; however, setup was a breeze. Clicked on add, device, scan nearby and put the outlet unit into pairing mode by clicking the front button several times. It just added, and I had controls for the parent and both channels (called outlet 1 and outlet 2)

So, ultimately you got it to join using the new app, along with the 2 children? Or did this take place in the classic app and they followed to the new app?

Hey all – so, it looks like ST also has a native handler that may work for this called, “Z-Wave Device Multichannel”

Can you guys try this out? I’m out of the office and don’t have any 2-Channels laying around to verify, but from what I’ve heard it should work in the new app.

Tagging @erocm1231 for clarity.

Exclude I had to do multiple times in both apps. Setting up after that was entirely in new app. No custom DTH.

1 Like

I posted about this here:

I think the best option right now is to try the latest device handler in our github and recreate the child devices.

1 Like

Which device handler are you referring to? I see a normal 2 channel one and a 2 channel alternate version in your github.


I an using the alternate version and it works good.

1 Like