Inovelli dual channel outlet issues

I will try this again. I had used the alternate device before and it didn’t seem to work but maybe it’s been updated or I installed it incorrectly somehow. if it doesn’t work, I can always go back to the MCD device handler. I would much rather have three devices on my main screen of the smart things app then just one, although it does work, so I shouldn’t complain too much. :slight_smile:

1 Like

I’m not sure if it was the fingerprint or because I had previously had chosen the MCD handler, but every time I removed and added the inovelli back it would default to the MCD handler automatically. So I had no choice.

1 Like

That is good to know, yours must have a different fingerprint than mine does because it doesn’t automatically use the MCD handler.

I will add a note in the KB knowledgebase that you may need to change the child device type from “Child Switch Health” to “Child Switch” before you delete them if the MCD is automatically chosen.

1 Like

@erocm1231, I’ve followed everything in the KB article but the last step to simply update the parent device does not create 2 children device/channels. It doesn’t specify if you need to change the DTH. I’ve left it with the alternate. I did try to update it to the default inovelli DTH but then it defaults to the MCD, which is sort of ok bc THEN it creates the children. The only issue is that the children channels are nested in the device attributes instead of separate devices in ST. I need separate bc I’m trying to use alexa to address channels separately.

Eric,

I wanted to let you know that I finally tried this again. At first, I didn’t think it worked because I didn’t have separate devices in the ST app for Outlets 1 and 2, but then I realized that they were in the “No room assigned” room. I guess I thought they’d show up in my Outdoor room automatically. Anyway, the installation didn’t work exactly as described in your article. I wound up with 4 child devices at first. But, I deleted them all (after changing the old ones from Child Health Device to Child Device) and then updated the main device, which re-created the correct child devices. Thanks.

1 Like

That is strange. After I delete the incorrect child devices (with the alternate device handler installed) all I have to do is click “Edit” for the parent device, scroll down to the bottom, and then hit update. This creates the new child devices for me. I don’t have to change anything on the page after I click “Edit” because the alternate device handler was selected in a previous step.

That’s what I did initially. But in your screenshot, it shows the “non-alternate” device handler selected by default after the last step. Should the alternate device handler stick in order to create child devices that show as separate devices in the app?

I removed the child devices and changed to using the “Z-Wave Dual Switch” (built in device so no custom handler required) and it will generate a “Z-Wave Binary Switch Endpoint”. Both outlets work perfectly.

Thanks, maybe I will give that a shot. Did it create 2 separate devices within ST? That’s my challenge bc that’s the only way Alexa will allow me to control them separately.

I’ve followed all of the instructions, added the DH, removed child devices, etc - I can see both child switches are independent switches, but both are perpetually stuck on “Checking Status” and neither can be directly controlled. I am able to control them in the ST Classic app (if I can scroll before the app kicks me out). Something with the new ST app. I’ve found several threads both on ST and the Inovelli pages, but no resolution that I can find. Any advice? I can’t add the independent switches to any scenes since the ST app can’t see them.
Separately (sort of) - since I’ve owned this device (nzw37), it’s been a headache. Every time the device gets unplugged from power, it gets deregistered from ST. This is the only Z-wave device I own that has this problem. So this is not my first go-round adding and setting up this device with the custom device handler, but IS the first time since migrating to the new ST app.

Follow-up to prior post…sort of by accident, I discovered that the new default handler, “Inovelli 2-Channel Smart Plug MCD”, actually get me where I need to go without the need to set up/assign the custom device handler. In the new Smartthings app, when adding this device to a scene or automation, it asks you to specify the settings for all 3 “parts”, i.e. the “both”, “Ch 1”, and “Ch 2” options. So even though I don’t see the separate switches as independent devices on the main screen, I am in fact able to independently use them in my automation, which is really what I needed anyway.
Which is great - because this thing STILL deregisters from my hub every time it gets unplugged. Using the default handler makes it much easier/faster to re-set-up all of the automations that use it.

I’ve been following the tutuorial here: https://support.inovelli.com/portal/en/kb/articles/how-to-use-the-2-channel-plug-indoor-outdoor-with-the-new-smartthings-app-smartthings

I’ve added the device handler, but when I go to select it from the drop-down menu under the device itself, “Inovelli 2-Channel Smart Plug (Alternate)” doesn’t show up as an option.

I went back to the Device Handlers page, and Inovelli 2-Channel Smart Plug (Alternate) is showing there as published.

Any ideas? I’ve also done the child device change from Child Switch Health to Child Switch with still no luck. Inovelli 2-Channel Smart Plug (Alternate) does not appear at any time as the option to select as the device handler.

Thank you for any pointers!

@erocm1231 If you could please comment, I’d appreciate it.

Sounds like you are almost there. The device handlers that you install show up at the very bottom of the list of handlers.

1 Like

Thank you Eric! I just did a huge face palm! I thought that all the handlers would populate in alphabetical order instead of at the bottom of the list. Once I found it at the bottom of the list I was able to select it and assign the child switches correctly! Thank you so much!

1 Like

You mentioned that it’s a default handler, does this mean that it now finally handles local automations or are they still cloud? @erocm1231 @Eric_Inovelli

I’m looking to restart my router and modem connected to the same plug and was wondering if this would be my best option. Any suggestions or recommendations would be highly appreciated. Thanks!

When I check the IDE, it shows Execution Location of “Cloud”.

I personally wouldn’t recommend this specific device for your use-case. If I were you, I’d stick with a single-outlet device, and use a Y-splitter to plug in both the router and modem to the same outlet. The multi-outlet is overkill I think, and I would question its reliability (although, since I have switched to the “new” default handler, I am not having any more issues with power outages causing the network to forget the device).

From what I understand, SmartThings hosts the device handler, but it is not considered local until they push the device handler down to all users hubs. Unfortunately they did not do this if it is still saying “cloud”.