SmartThings Community

Info shown on Dashboard


(Tim) #1

New (very!) to SmartThings and have started with 2xWater Leak detectors, a Hub (presumably V3) and a motion detector. The leak detectors can report temperature and battery status, is it possible to display all these things on the Dash or is it stuck on ‘Wet’ or ‘Dry’??
Seems to be missing an opportunity to be a bit more useful…
Also, can the temp values be pulled out somehow to display as a graph?

Thanks in advance,

Tim


#2

Welcome to ST and this Community! There is a ton of useful information you’ll be able to find.

That’s the way ST’s default device handler works. That can be easily changed with a custom handler, more so with the Classic app vs the new app.

Yup, with Google Sheets. Take a look at this SmartApp (again, use the Classic app to install and use):


(Tim) #3

Thanks John, appreciate the speedy response!

By ‘Custon Handler’ where would I go to look at how to do that?

I’ll take a look at the ‘simple event logger’. I’m already preferring the Classic App, mainly because it works in landscape mode on my iPad and doesn’t pretend to be a giant phone app!

As I said, I’m completely new to SmartThings but willing to invest both time and money to get the best from it. Next purchase will be some smart lights so I can make the motion detector actually do something when it detects motion. I’ve got an Echo and a Dot so hope to be able to make use of both systems together at some point.
I very nearly didn’t bother because I originally purchased one leak detector thinking that my new Samsung TV actually had a SmartThings Hub built in (missed opportunity there Mr Samsung) and was about to send the detector back to Amazon when I thought sod it, but a Hub!


(sidjohn1) #4

#5

If you go into the IDE (developer tools), you can create your own handlers from a template or from code from another developer. If you chose the one your sensor is using and modify the line starting with “main”, you can pick which tile is the main one.

I’m on my mobile phone now (last minute shopping w/wife, so I’m staying occupied…), but search the Community for threads on “using custom code” and or check here:

http://thingsthataresmart.wiki/index.php?title=Using_Custom_Code


(Tim) #6

It was going well until I got to the bit about linking to my device - no devices showing, fine, I’ll add it in using the ‘Add one’ option…took me to a ‘Create Device’ page.
‘Name’ I assume I can make something relevant up
‘Label’ doesn’t seem to be mandatory so skip that
same for Zigbee Id
‘Device Network ID’ is needed but I can’t seem to find that anywhere within the new or Classic SmartThings app. The sensor boxes list an installation code and MAC address.

Next issue comes at the next dropdown where it wants a ‘Type’ and there is a default in there of 2015 Samsung Smart TV. The actual dropdown list doesn’t include anything obviously that’s obviously a Samsung 2018 Water Leak Sensor (it includes loads of interesting looking stuff though!!). The nearest thing looks like a SmartSense Moisture Sensor which Google seems to suggest is an older version.
So, seem to have hit a wall here!

Tim


#7

You don’t want to create a new device because it already exists. You just want to change the device handler its using. You want to create a new Device Handler from an example, which will be Smartsence Moisture Sensor. Give it a name unique to you, make changes, save it and publish for yourself. When done, edit the existing device’s Type to what you just created. It should be at the bottom of the Type list.


(Tim) #8

OK, thanks, I can see where I went wrong but… having now tried to Create New Device Handler - From Example, I can select the SmartSense Moisture Sensor (all code pertains to the right device) but when I click ‘Create’ I get a red error message reading:
“Org.springframework.security.access.AccessDeniedException: Run Locally Permission not allowed for DeviceType: 434b8d60-35c2-4f06-8410-b90ef7382e4c”

Back to being stuck again!

some more info - trying this on a MacBook, using Safari browser.

Tim


#9

Find this part of code up near the top:

runLocally: true

Change true to false and then you’ll be fine.