Inconsistent Android mobile presence


(Mike T) #1

I saw a thread titled “Inconsistent iPhone Presence” so I wanted to start a new thread because the Android development might be separate from the IOS development and I don’t want this to be buried in the comments.

Just like the Apple people report, though, I find the mobile presence feature to be hit-or-miss. I am sitting 20 miles from home, comfortably outside the fence I set up :slight_smile: And yet the Smartthings app on my phone has not recognized I have left. Yes, the GPS is on, and in any event I’m sure my phone knows roughly where I am thru wifi signals. Its only when I restart the app that my location gets updated. This seems to happen periodically (eg this isn’t the first time, its one of several). The reverse also happens. When I arrive home the Smartthings app often fails to recognize this.

As a consequence my home security system basically doesn’t work unless I manually go into the Smartthings app and set my presence to “away”. Not exactly the automation I was hoping for. And when I arrive home since Smartthings doesn’t know I’m there it sets off the siren. Again, not exactly desired behavior.

Has anybody found a fix for inconsistent mobile presence detection? Is all I can do restart the app whenever I leave or arrive?

One thing I would do, if Smartthings would add hooks to Tasker, is have Tasker realize I am away and change the presence location. Tasker is generally reliable and would be perfect for this workaround.


(Steve S) #2

Yep - I’m one of the iPhone people with this issue - I have found that I don’t have to restart the app though… if I “pull to refresh” the page containing my mobile presence, it will update.


(Bob) #3

@miket Are you using a Samsung Galaxy S6?
I had lots of problems with mine and my wife’s S6 and this was cured by turning off app optimisation.
Turning it off hasn’t impacted on battery usage so to be honest I’m not sure of the value of using it anyway.


(Eugene) #4

hello. I am have issues with my galaxy s5 and s7 also my showing correct presence when the kids are away. How did you turn off app optimization ?


(Bob) #5

@erehc79 .
Settings.
Battery.
Details.
Then turn off app power saving.
As said before, works for us.


(Eugene) #6

Thanks… I will try that.


(Eugene) #7

That worked. thanks for the help.