IKEA tradfri outlet

I use “ZigBee Switch” :slight_smile:

I used Zigbee Switch, working fine.

Im having an issue pairing these plugs. I bought 5 of them. 3 of them paired up just fine.

The other 2 plugs I tried pairing several times but they would not work. Theres no issue adding the ‘‘thing’’. It shows up in IDE. I update them to zigbee switch. It shows as Zigbee switch in the app. However, when I try to power them on and off, it just hangs. Its never actually able to control the switch.
I tried deleting and re-adding the 2 switches several times but keep running into this issue. Anyone have an idea whats going on?


Is anyone able to offer some advice on pairing these outlets to the smartthings hub.

I’m trying to pair an outlet but my hub can’t see it. I’ve tried switching the outlet on and off and also holding the reset button for 3 and 10 seconds but still no luck.

I’ve also tried adding the outlet automatically and by selecting manually add in the smartthings app.

I read in a few places that a remote might be needed to pair but i can’t really understand why this would be necessary…

Also when i press the reset button I don’t really feel much and there’s no flashing on the lights to suggest it’s going into pairing mode.

Any instructions or step by step guides would be really appreciated otherwise I’ll have to send them back and they’re the only zigbee outlets I could find :frowning:



The two I bought in the UK paired on first attempt. I pressed and held the rest button for about 10 secs and then searched in the smartthings app and added them.

Now saying that, I bet I have jinxed myself now, because I am buying two more this afternoon and I bet they don’t connect :slight_smile:


Paired 3 successfully over the weekend. Hopefully below might help if you want to compare. When I reset them they were powered on:

  • Plugged them in fresh out of the packaging. They were powered on, solid white light.
  • Used a paper clip to press the reset button. Heard a click and the light started flashing,
    then went to a dull glow after holding the rest button in for 12 seconds.
  • Added Thing in the phone app and gave it a name, pressed save.
  • Logged into the IDE and set them all as Zigbee Switch Power

Working very well since.

If they still won’t pair, I would send them back as faulty.


Thanks kilters.

How audible was the click that you heard? How hard did you have to press the reset button?

I feel like I may not have been hitting the button correctly. I barely heard a thing and the button must have been tiny as it barely moved.

At least i know the light should flash and glow now. That’s great information.



There is a definite audible click which is the same as when the outlet turns on and off. You can hear it in normal operation.

Pressing the reset button, you should feel that you pressing something in. I used a reasonably large paper clip. It could be the reset switch is slightly off centre from the hole so try hunting around for something that clicks.

Hope it works.

You hit the nail on the head. The pin i was using wasn’t depressing the reset button. A paper clip has done it.



Yes, just to add for others…you need to press the reset button quite hard…if you do this when the plug is in a socket, then the light should slowly flicker. Be very close to your hub, and it should find it quite quickly.

Thanks for the comment on the Trådfri bulbs. I just wanted to circle back and offer my findings. Received my XBee yesterday, and it does indeed look as though the Trådfri outlets are decent little repeaters. Not the best range, but in my small home they’re working just fine. Since they’re so inexpensive, you could do well by picking up several of them, and still not break the bank.

Anyway, I’ve been running them for a week and a half with no problems and no dropped Xiaomi devices. I did have an issue a few days after installing one, when I decided to pair a Trådfri bulb with my hub instead of my Hue bridge. That cause the Outlet to drop and that took many of my Zigbee devices down. Since removing the bulb, and installing a second Trådfri outlet, it’s been very stable.

Here are the results of it with my Hubitat hub.

Works great with the Canadian version! Thanks!!!

Hey David, I am in the same boat as you. Let me know if you figure out how to make this work!

I’ve just got my new hub, bought 2 of these sockets from Ikea. Tried to reset them but cannot get the app to find either of them. Any ideas?

So I’ve kind of sorted it. Add it as one of the known types of socket, hold down the reset when it says something like ‘press button B 3 times’. It then finds it as ‘Thing’ with a type of device ‘2015 Samsung Smart TV’

Then change the type to ZigBee Socket Power!

How did you set them up ?

From the App, go to Add Device Manually, choose Outlets.

Select one of the options such as Osram. It then comes up with a message about holding the button to reset. At this point I put a pin into the reset hole and held it for about 10 seconds. (not sure if this reset step is necessary as I didn’t try without).

It then find the device but lists it as ‘Thing’ and for some reason lists it with a device type of ‘2015 Samsung Smart TV’.

Log into the website, find the device and change the type to ‘ZigBee Socket Power’, rename it and give it a label.

1 Like

I can’t seem to find the device with my v1 hub. Has anyone had success with this combo? I’ve had no issues with other tradfri devices, but have had issues with other zigbee devices that want insecure rejoin.

I cannot get the latest 2 tradfri outlets to pair with a V2 hub either. I have 3 running smoothly for the last few weeks. Picked up a couple more and neither will pair! I have also been having some flaky zigbee devices as of the last day or so. Maybe its related. any suggestions?

The method that has worked for the other three is to press reset button for 10 seconds, wait 10 seconds to search for a thing. Then go to IDE and change to a zigbee switch

1 Like

Also picked up a single Tradfri outlet today and could not get it to pair. Tried all sorts of permutations with holding in the factory reset pin, cycling power, etc. with no luck.