Ignore sensor feedback between certain hours

Hello All,

Even if I started my smart home projects for over one year now, each time I do a new configuration I realize I am still a rookie :P.

I need your help with the following situation:

I use a smartthings v2 hub and several sensors and devices throughout the house.
I have a Xiaomi motion sensor on the hallway controlling the Ikea bulbs during night only. Basically I use webcore (see below snapshot) to set up the lights to turn on if there is movement on the hallway between 8pm and 7am and turn off if there is no movement for 20 seconds. there is also an open/close sensor in the piston but that can be ignored.
The problem is that, even if I use time restriction, the 20 seconds countdown takes place in whenever motion is detected on the hallway (or better say not detected after it has been triggered), meaning I get to see the countdown in webcore even if I am outside the specified timeframe. This means the network itself get’s flooded with events of the sensor even when it should be ignored.
Countdown

Is there any way to make Smartthings/webcore simply ignore the sensor and only consider the sensor activity between the specified hours? Indeed the lights do not turn on outside the timeframe, however the piston gets executed…

Thank you!

You have to set the timerestriction for every IF that needed.

1 Like

Thank you Jepajo,

Your response made me think of a way to stop the countdown from starting when not needed.

I did set a restriction indeed, however not a time restriction, but a device state restriction, basically making the last statement take place (the one with motion inactive), only if the light are on :smiley:

Thank you!

1 Like

I have added “Guest” mode to location modes. It is controlled by virtual switch “Guest(s)”.


During that time period, no motion and door contact sensors are reporting, and some automations (lights and security) are not executed. Also outdoor cameras are recording full time in that period.
When guests are gone i do change mode to appropriate mode, and all Automations continue.
Hope this helps a little.

1 Like

I think most people in this thread are aware of this, but just to be absolutely clear for others who might come in who have less familiarity with the platform…

There are some home automation/security systems which allow you to turn off a sensor for a specific period of time. But smartthings is not one of them.

The individual devices will continue to send reports to smartthings based on whatever their own internal parameters are.

What you as a smartthings customer can control is whether or not your automations will run during a fixed period of time when that sensor reports. And, of course, if you have any automations that are doing polling of the device, you can turn that off.

So if you are concerned about network traffic, you are going to continue to get some network traffic from the sensor 24 hours a day even if you aren’t going to have any automations that react to that report. Zigbee Sensors will still check in every hour. Sensors which also report temperature or humidity will continue to do that. And if a motion sensor detects motion, it will still send in the report.

What you can “turn off“ is the automation activity, so that you can treat the sensor as an automation trigger only during specific times or conditions. So the topic title is exactly right: you can tell smartthings to ignore the sensor at certain times. But you can’t tell the sensor not to report unless it happens to be a device with configurable firmware parameters.

Like I said, I suspect most people in this thread already know that, but I just wanted to be clear for future readers. :sunglasses:

2 Likes

Thank you JDRoberts for the detailed description.

Indeed I have noticed the behavior you are explaining. However I managed to ‘prevent’ the sensor to report activity (most importantly the lack of movement) by adding a restriction before line 49 (in the snapshot I attached above), for the last statement to run only if the lights are already on.

This actually resolved the issue I had… the sensor sends traffic to SmartThings whenever it detects motion only between 8pm and 7:15am, and then sends traffic to SmartThings whenever motion stops (and subsequently starts the 20 sec countdown) only if the lights are on at the time the motion stops.

Basically even if the sensor itself records active/inactive motion between 7:15am and 8pm (so outside the restrictions) those activities are completely ignored by SmartThings due to the restrictions.

1 Like