"If it aint broke, don't fix it": Lesson learned


(Monte Montemayor) #1

So… when I first started using ST and setup my 1st motion sensors, ya’all really helped me fine tune placement and tweaking. Originally the delays to turn the lights on were not acceptable. Then I bought Hue Sensors and used the Hue Hub and the sensor activation/lights on was almost immediate. Life was good. Then I had the bright idea (grrrr) to move the Hue Sensor to the ST hub using the DH so I could manage them all in 1 place. Now the problem is that the lights are again delayed by probably 1-2 seconds. Also, my lights auto shut off only works about 60-75% of the time (and usually not all lights turn off either). I am essentially using CoRE to turn them on but Smart Lighting to turn off. Can someone confirm:

  • Using Hue Motion Sensor directly in ST, I should expect a delay since the lights are connected to a Hue Hub
  • Is it advised to using 1 app (such as CoRE) to turn on and a different app to turn off (such as Smart Lighting)

One big learning for newbies (and I put myself in that category), find a sensors that works for what you’re trying to accomplish and stick with it if possible. The ST sensor didn’t work well and though I love the Hue Sensor, it’s kind of a hassle to make it do what I need. Going forward, I will only buy Iris Motion Sensors.

Thanks.


(Monte Montemayor) #2

I also learned something else. It’s a one way street. Once you move the Hue Motion Sensor from Hue Hub to ST (via the DH), even when you re-set it, the Hue Hub will not recognize it, though the ST hub will. I even removed the batteries for 5 min, hit he re-set switch per the instructions and still the Hue Hub would not find it, but ST did immediately. This is my experience- just FYI.


(Jason) #3

When using the Hue Motion directly to the hub it is a direct connection. When you add the Motion sensors to ST they no longer run local and now have to use the cloud, that is where your delay is coming in. I was able to add my back to hue hub if I want to. Make sure you take the batteries out of the motion sensor and use the reset button in the motion sensor.


(Monte Montemayor) #4

Thats what I am trying to do actually. I tried and tired without success. Is there a trick? :slight_smile:


(Jason) #5

Make sure you take the batteries out of the motion sensor and use the reset button in the motion sensor.


(Jason) #6

Also, I use CoRE and my delay is less no more than 1 second.


(Monte Montemayor) #7

Humm, I am probably doing something wrong. Just to clarify, you are using CoRE when its paired to ST, not when it’s paired to Hue Hub, correct?


(Jason) #8

Correct, I had an issue in the begining and modified the code to have shorter interval for sensing motion and that fixed the issues for me.


(Jason) #9

@zonomo I see you are in the main post, that is good. There are 2 DTH in there. The 1st was done by the original author. The 2nd was done by another community member. They are both the same except the 2nd one has a fix in it for the luminance sensor. If you use the 2nd dth you can alter line 156 for the motion times, right now it is set to 30 seconds. I changed mine to 10 seconds, try it and see if it fixes your delay. This is the line with the modification. The 10 right before the 600 is what you want to change it will show 30 on yours just change to 10, save and republish.

configCmds += zigbee.configureReporting(0x406,0x0000, 0x18, 10, 600, null) // motion // confirmed


(Monte Montemayor) #10

OK - I am going to try that. Also, (sorry for the dumb question), I update the code, save and then re-publish, correct? Anything else I have to do?


(Jason) #11

That is correct, and no, nothing else to do. Let me know how you make out. Also, just so you know I moved from Hue to ST because the hue motion when they are hooked up to the hue hub do not have any rules. Example, I was in my stairs in the light turned of because there was no motion, with Core you can tell it to stay on until there is no motion and then put a wait on it so it would turn off after no motion for 1 min. Then you would select cancel on piston state change which makes the piston start over when it detects motion while it is in the off cycle, the result the light won’t turn off.


#12

Philips has added a bunch of rules options for the Hue motion sensor in Hue labs. These are essentially beta releases of features that they are testing, but there’s a lot of helpful stuff there.

Worth taking a look at if you are using the hue bridge. :sunglasses:


(Jason) #13

JD, that is the exact reason I moved to ST no rules, now they are making them? Go figure. However, I still feel that even with these new rules, using CoRE or WebCoRE is the best way to go.


(Jason) #14

I just looked at the new rules, kinda a joke, you have to install each one separate. They need a rule app, not this, wow.


#15

That’s their beta program, it’s not intended as a rules engine. It just lets people try some of the new stuff they’re working on. Eventually, whatever it is gets moved to the main app if they decide to make it a regular feature. :sunglasses:


(Monte Montemayor) #16

Thank Jason, I’ve updated my DH. I am going to reinstall them just to be 100% sure. I’ll let you know if this solves it for me. Thanks!


(Jason) #17

How did you end up?


(Monte Montemayor) #18

It worked pretty well. Still a hair slower than the native Hue Hub connection but workable. I think for times when I really need instant-on (mainfloor bathroom where I’ll have guests reaching for the switch), I’ll use a native Hue Sensor w the Hue Hub. But for almost everything else, I’ll use ST. Thanks!