IDE Not Saving

So I am editing my device, saving and publishing. I go to my device and click on it and look at the code and it has reverted to the a previous version of the code. Am I going mad?

Did you happen to have a wifi interruption? The IDE will store a local copy as you are editing, and it can push that back to the active IDE on a network disconnect.

This just happened to me. 2 crazy things:

  1. The device type code it currently shows is for a previous version that I made a while ago, it seems to have reverted by itself.
  2. It is impossible to update the code - if I make any changes, no matter how big or small, if I save and/or publish it says that it has saved correctly or published correctly. but it has not! refreshing the page sees the old code back there again.


no WiFi disconnect. Bouncd the box and tried chrome and IE. Same behaviour. Going to check this evening.

@oktane I’ve managed to get around this issue by starting new device types / Smartapps. If the device type or smartapp is doing this there seems to be no fix other than copying all the code out into a new device type or smartapp and changing the name. Annoying - but at least it works …

@jody.albritton ST, please recognise and fix this

The situation is getting worse.

Today I tried a new device handler for an old device. The results were insane. The new look from the new device handler showed in the iphone app, and according to Smartthings IDE the new device handler was the associated handler - yet when events occurred on the device Smartthings handled the events with the old code. No way around this - so cant test the new handler.

What a mess