SmartThings Community

I opened the Samsung Connect app a MISTAKE

I had 64 items (combo of dimmers, switches, plugs, shade, and locks) well integrated and working well on SmartThings Classic until I made the mistake of opening the latest version of the Samsung Connect app. BIG mistake.

On opening the Samsung Connect app it created a new location and moved all but the shades to the new location (Home). It also made available only 16 of the 64 items to be manually controlled. There is no way to add to rooms, scenes or anything I can actually use to control beyond the 16 units. Oddly if I want to create automation I can include all of the other controllers but can’t operate manually any that weren’t the original 16 transferred.

My goal is to stay with the classic. I would like to consolidate all units back to one location since I only have one house. If I delete the newly created location what happens to all of the items associated with this location?
Is there a way, short of talking to the impossible to reach support, to re-associate the location to the old location? Has anyone solved this problem?

One option is to go through each of the 64 items and remove them from the network and reconnect them and redo the automations with a clean location. A fresh start. I would rather not do that. I’d like to find a way to revert to what I had three days ago.

Don’t delete or physically reset anything!

See the following FAQ for how to get access to your devices again: ( The topic title is a clickable link)

Definitely don’t delete anything. You sure the devices aren’t tucked away in a room?

So I made an account just to reply to this thread.
First - important details: Recent Iris refugee, very smooth transition (other than a few z-wave unpairing/pairing gymnastics) to SmartThings platform - about 40 devices, some automations, cameras, Alexa integration, nothing fancy. Using iOS.

HUGE HUGE mistake of opening new app the other morning. It prompted me to move some things into rooms - ok, whatever - then when it fully opened about 1/3 of my devices were missing and about 2/3 of the ones actually shown were showing disconnected. Strange but maybe just a caching/updating/syncing glitch or whatever. Now begins my absolute hell-journey with SmartThings.

Call from wife - Alexa not working. I check and notice items are STILL showing disconnected an hour later. Ok, now we seem to have a problem. I start poking around in the classic and the new app. I finally figure out I have a new location! Great! My “cloud” devices (Arlo, Ring doorbell, etc) and all of my automations are on one “location” along with a sprinkling of some hardware devices (including the hub). The other location has the majority of the remaining hardware devices on it. Oh, and Alexa no longer works, I cannot create new automations, and I can’t “move” devices to a new location following any of the instructions posted anywhere. I have walked through this with phone reps, emailed support, sent screenshots, etc - I DO NOT have the ability to change a device’s location using the app (iOS). The rep even walked me through it and once he put down his Samsung phone and picked up one of their iOS devices, he saw the option was not there. This half-baked app seems to have absolutely wrecked my very recent complete migration. The customer support is completely laughable with 1.5hr hold times!!! This is an incredibly frustrating experience. I am not a developer or computer programmer but I am a techie through and through (electrical engineer) so I’m not exactly scared of trying everything and anything. I’ve used the app on my iPhone and the web interface. I tried logging on with my Chromebook running the Android app but that method is not supported (I thought I had outsmarted the system until I couldn’t log in).
Any suggestions?

if you have two locations with devices in both, probably best to contact ST support at https://support.smartthings.com and work with them to merge your devices into a single location. I would be afraid to offer advice as I can not see everything going on with your system. ST support is better equipped to assist with your situation.

Hello! Thank you for the reply!
I have contacted support a total of seven times now. Four phone calls and three emails. They have not offered to “merge” anything but have instructed me how to do it using the “new” app. As I previously stated, the iOS app does not seem to have the ability to change device locations. I may be ignorant of SmartThings but it seems like the intention is I can move all of my devices to the new location rather seamlessly and then simply delete the newly empty location.
Not to belabor the point, but contacting customer service has been a complete “swing and a miss” for me… Thank you though - it definitely seems like it should be the logical starting place for a somewhat complicated problem for a newbie.

first selection the location you want to move the devices from. You can choose Location by selecting the three bars in the upper left of the screen, locations are in a pull-down within the image at the top.

after you have selected the location, you go to the Devices section, click the 3 dots in the upper right of the screen, select Edit, select the device. from there you can probably click on the location field to move the device to another location.

I have never tried it and they have moved everything around with the most recent update

Edit: Never mind - @prjct92eh2 shows my instructions do not work :slight_smile:

I’ve been playing with two locations for a couple days. The edit device screen doesn’t let you edit the location like it does the room

Exactly! I’ve sent this identical screencap to SmartThings support.