I can not remove a device

I have a standard switch that I can not remove, Actually it is a phantom device I have tried force deleting the device but it keeps showing up in my device list. the device I think it is I have removed and added back but this phantom device will not remove no matter what I do.

Any ideas on how I can remove it?

If there are smartapps attached to the device you may have to uninstall them first. you may also want to contact support support@smartthings.com

1 Like

There was a smart app but I removed the device from that.

Well I sort of figured it out, I removed the device i thought it was then used the “replace device” button on the app and added it back and now I am good to go.

Thought I’d chime in, in case anyone else comes here looking for help removing a device. I had a similar problem where a switch wasn’t working so I wanted to remove it, exclude it, and re-add it. In the app the Force Delete button didn’t do anything. The screen would change as if it accepted the button being hit, but my device was always still there (not part of any apps). I also tried excluding it but nothing ever changed. The app would poll the current on/off state properly when I toggled the switch manually, but I couldn’t change the state from the app at all. It would change the tile to “Turning On” and not work. When I refreshed it, it’d go back to showing the off state. I ended up removing the device from the IDE and went back to trying to exclude it/re-include it.

In the IDE when I went to Live Logging it showed no messages when I was doing any of this, same with Hub Events. So I tried doing the Restart Hub option in the utilities, nothing happened, no logs, no events, no reboot. Z-wave Repair same thing. Finally realized that it wasn’t excluding the device because none of my hub commands were actually happening. Weird thing is that everything else in the network was working fine. Motion sensors were firing, notifications coming in, I could snap pictures on my cam, etc. Those things would all log messages, just not hub-related ones or this one switch.

Ended up pulling the plug and the batteries so it’d fully power down, let it sit for a minute, then hooked it back up. When I did that my live logs started showing messages again when I did hub commands, and the switch excluded/included on the first try.


1 Like

Thank you vors! I had to do the same exact thing… pull the batteries and let the hub restart. After I did that, the “Remove device” functionality started working in the app. Frustrating indeed, but I was very happy I came across your post. Thank you again.

Thank you for this post. You described the full scenario I was having with some Lutron dimmers. I had tried everything till I came across this post!

Oh thank you for this. I ran into this now and after weeks of troubleshooting this is what fixed it. Restart and reinstall.